[20220308] - Core - Inadequate content filtering within the filter code
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An issue was discovered in Joomla! 4.0.0 through 4.1.0. Inadequate content filtering leads to XSS vulnerabilities in various components.
Why it matters now
EPSS 0.00674 52nd percentileScored 2026-11-07
Fix Fixed joomla/filter (Packagist): 1.4.4, 2.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Joomla! | Joomla! CMS | 4.0.0-4.1.0 | — | No fix listed | CNA |
| Joomla! | joomla/filter | 1.0.0-1.4.3 & 2.0.0 | — | No fix listed | CNA |
| — | joomla/filter (Packagist) | before 1.4.4 | 1.4.4 | Patch available | GHSA-qcv6-h33g-hvrc |
| — | joomla/filter (Packagist) | 2.0.0 to before 2.0.1 | 2.0.1 | Patch available | GHSA-qcv6-h33g-hvrc |
- Joomla! CMS VendorJoomla! Affected 4.0.0-4.1.0 Fixed in — No fix listed CNA
- joomla/filter VendorJoomla! Affected 1.0.0-1.4.3 & 2.0.0 Fixed in — No fix listed CNA
- joomla/filter (Packagist) Vendor— Affected before 1.4.4 Fixed in 1.4.4 Patch available GHSA-qcv6-h33g-hvrc
- joomla/filter (Packagist) Vendor— Affected 2.0.0 to before 2.0.1 Fixed in 2.0.1 Patch available GHSA-qcv6-h33g-hvrc
Remediation
- Fix · GHSA-qcv6-h33g-hvrc joomla/filter (Packagist) Fixed in 1.4.4 Advisory →
- Fix · GHSA-qcv6-h33g-hvrc joomla/filter (Packagist) Fixed in 2.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23800
- 2026-10-03 Alias added: GHSA-qcv6-h33g-hvrc
References
Advisory 2
More Joomla! vulnerabilities
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2017-06410 SQL injection vulnerability in Joomla! 3.7.x before 3.7.1 allows attackers to execute… CVSS 3.0CRITICAL 9.8
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2016-07280 The register method in the UsersModelRegistration class in controllers/user.php in the… CVSS 3.0CRITICAL 9.8
- TI-2023-09555 [20230201] - Core - Improper access check in webservice endpoints KEVCVSS 3.1MEDIUM 5.3
- TI-2015-07045 Joomla! 1.5.x, 2.x, and 3.x before 3.4.6 allow remote attackers to conduct PHP object… CVSS 2.0HIGH 7.5
Sources
- CVE-2022-23800 · CVE Program
- CVE-2022-23800 · NVD
- FIRST EPSS
- GHSA-qcv6-h33g-hvrc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences