Read the docs
TI-2022-08558 Aliases CVE-2022-24744GHSA-w267-m9c4-8555

Insufficient Session Expiration in shopware

Priority LOW 17CWE-613Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-613.

Summary

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions user sessions are not logged out if the password is reset via password recovery. This issue has been resolved in version 6.4.8.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00485 42nd percentileScored 2026-11-07
Fix Fixed platform (shopware): 6.4.8.1shopware/platform (Packagist): 6.4.8.1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformbefore 6.4.8.16.4.8.1Patch availableCNA
—shopware/platform (Packagist)before 6.4.8.16.4.8.1Patch availableGHSA-w267-m9c4-8555
—shopware/core (Packagist)before 6.4.8.16.4.8.1Patch availableGHSA-w267-m9c4-8555
  • platform Vendorshopware Affected before 6.4.8.1 Fixed in 6.4.8.1 Patch available CNA
  • shopware/platform (Packagist) Vendor— Affected before 6.4.8.1 Fixed in 6.4.8.1 Patch available GHSA-w267-m9c4-8555
  • shopware/core (Packagist) Vendor— Affected before 6.4.8.1 Fixed in 6.4.8.1 Patch available GHSA-w267-m9c4-8555

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.4.8.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.4.8.1 Vulnerable ·shopware

Remediation

  • Fix · CNA platform (shopware) Fixed in 6.4.8.1
  • Fix · GHSA-w267-m9c4-8555 shopware/platform (Packagist) Fixed in 6.4.8.1 Advisory →
  • Fix · GHSA-w267-m9c4-8555 shopware/core (Packagist) Fixed in 6.4.8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24744
  2. 2026-10-03 Alias added: GHSA-w267-m9c4-8555

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources