Read the docs
TI-2022-08560 Aliases CVE-2022-24746GHSA-952p-fqcp-g8pc

HTML injection possibility in voucher code form

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In affected versions it is possible to inject code via the voucher code form. This issue has been patched in version 6.4.8.1. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00844 58th percentileScored 2026-11-07
Fix Fixed platform (shopware): 6.4.8.1shopware/platform (Packagist): 6.4.8.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformbefore 6.4.8.16.4.8.1Patch availableCNA
—shopware/platform (Packagist)before 6.4.8.16.4.8.1Patch availableGHSA-952p-fqcp-g8pc
—shopware/core (Packagist)before 6.4.8.16.4.8.1Patch availableGHSA-952p-fqcp-g8pc
—shopware/storefront (Packagist)before 6.4.8.16.4.8.1Patch availableGHSA-952p-fqcp-g8pc
  • platform Vendorshopware Affected before 6.4.8.1 Fixed in 6.4.8.1 Patch available CNA
  • shopware/platform (Packagist) Vendor— Affected before 6.4.8.1 Fixed in 6.4.8.1 Patch available GHSA-952p-fqcp-g8pc
  • shopware/core (Packagist) Vendor— Affected before 6.4.8.1 Fixed in 6.4.8.1 Patch available GHSA-952p-fqcp-g8pc
  • shopware/storefront (Packagist) Vendor— Affected before 6.4.8.1 Fixed in 6.4.8.1 Patch available GHSA-952p-fqcp-g8pc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.4.8.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.4.8.1 Vulnerable ·shopware

Remediation

  • Fix · CNA platform (shopware) Fixed in 6.4.8.1
  • Fix · GHSA-952p-fqcp-g8pc shopware/platform (Packagist) Fixed in 6.4.8.1 Advisory →
  • Fix · GHSA-952p-fqcp-g8pc shopware/core (Packagist) Fixed in 6.4.8.1 Advisory →
  • Fix · GHSA-952p-fqcp-g8pc shopware/storefront (Packagist) Fixed in 6.4.8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24746
  2. 2026-10-03 Alias added: GHSA-952p-fqcp-g8pc

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources