Read the docs
TI-2022-08562 Aliases CVE-2022-24748GHSA-83vp-6jqg-6cmr

Incorrect Authentication in shopware

Priority LOW 36CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.

Summary

Shopware is an open commerce platform based on the Symfony php Framework and the Vue javascript framework. In versions prior to 6.4.8.2 it is possible to modify customers and to create orders without App Permission. This issue is a result of improper api route checking. Users are advised to upgrade to version 6.4.8.2. There are no known workarounds.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00759 55th percentileScored 2026-11-07
Fix Fixed platform (shopware): 6.4.8.2shopware/core (Packagist): 6.4.8.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformbefore 6.4.8.26.4.8.2Patch availableCNA
—shopware/core (Packagist)before 6.4.8.26.4.8.2Patch availableGHSA-83vp-6jqg-6cmr
  • platform Vendorshopware Affected before 6.4.8.2 Fixed in 6.4.8.2 Patch available CNA
  • shopware/core (Packagist) Vendor— Affected before 6.4.8.2 Fixed in 6.4.8.2 Patch available GHSA-83vp-6jqg-6cmr

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.4.8.2Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.4.8.2 Vulnerable ·shopware

Remediation

  • Fix · CNA platform (shopware) Fixed in 6.4.8.2
  • Fix · GHSA-83vp-6jqg-6cmr shopware/core (Packagist) Fixed in 6.4.8.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24748
  2. 2026-10-03 Alias added: GHSA-83vp-6jqg-6cmr

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources