Read the docs
TI-2022-08657 Aliases CVE-2022-24845GHSA-j2x6-9323-fp7h

Integer bounds error in Vyper

Priority HIGH 76CWE-190Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.

Summary

Vyper is a pythonic Smart Contract Language for the ethereum virtual machine. In affected versions, the return of `<iface>.returns_int128()` is not validated to fall within the bounds of `int128`. This issue can result in a misinterpretation of the integer value and lead to incorrect behavior. As of v0.3.0, `<iface>.returns_int128()` is validated in simple expressions, but not complex expressions. Users are advised to upgrade. There is no known workaround for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01426 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vyper (vyperlang): 0.3.2vyper (PyPI): 0.3.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vyperlangvyperbefore 0.3.20.3.2Patch availableCNA
—vyper (PyPI)before 0.3.20.3.2Patch availableGHSA-j2x6-9323-fp7h
  • vyper Vendorvyperlang Affected before 0.3.2 Fixed in 0.3.2 Patch available CNA
  • vyper (PyPI) Vendor— Affected before 0.3.2 Fixed in 0.3.2 Patch available GHSA-j2x6-9323-fp7h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:*before 0.3.2Vulnerablevyperlang
  • cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:*:*:* Versions before 0.3.2 Vulnerable ·vyperlang

Remediation

  • Fix · CNA vyper (vyperlang) Fixed in 0.3.2
  • Fix · GHSA-j2x6-9323-fp7h vyper (PyPI) Fixed in 0.3.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24845
  2. 2026-10-03 Alias added: GHSA-j2x6-9323-fp7h

References

  • TI-2024-16182 Vyper bounds check on built-in `slice()` function can be overflowed CVSS 3.1CRITICAL 9.8
  • TI-2024-14992 concat built-in can corrupt memory in vyper CVSS 3.1CRITICAL 9.8
  • TI-2024-16184 Vyper array negative index vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-11796 Multiple evaluation of contract address in call in vyper CVSS 3.1HIGH 8.2
  • TI-2024-21531 vyper performs double eval of the argument of sqrt CVSS 3.1MEDIUM 5.3
  • TI-2024-21527 vyper performs incorrect topic logging in raw_log CVSS 3.1MEDIUM 5.3
See all 37 →

Sources