Server-Side Request Forgery (SSRF) in Shopware
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Shopware is an open commerce platform based on Symfony Framework and Vue. In affected versions an attacker can abuse the Admin SDK functionality on the server to read or update internal resources. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | platform | before 6.4.10.1 | 6.4.10.1 | Patch available | CNA |
| — | shopware/platform (Packagist) | before 6.4.10.1 | 6.4.10.1 | Patch available | GHSA-7gm7-8q8v-9gf2 |
| — | shopware/core (Packagist) | before 6.4.10.1 | 6.4.10.1 | Patch available | GHSA-7gm7-8q8v-9gf2 |
- platform Vendorshopware Affected before 6.4.10.1 Fixed in 6.4.10.1 Patch available CNA
- shopware/platform (Packagist) Vendor— Affected before 6.4.10.1 Fixed in 6.4.10.1 Patch available GHSA-7gm7-8q8v-9gf2
- shopware/core (Packagist) Vendor— Affected before 6.4.10.1 Fixed in 6.4.10.1 Patch available GHSA-7gm7-8q8v-9gf2
Remediation
- Fix · CNA platform (shopware) Fixed in 6.4.10.1
- Fix · GHSA-7gm7-8q8v-9gf2 shopware/platform (Packagist) Fixed in 6.4.10.1 Advisory →
- Fix · GHSA-7gm7-8q8v-9gf2 shopware/core (Packagist) Fixed in 6.4.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24871
- 2026-10-03 Alias added: GHSA-7gm7-8q8v-9gf2
References
Patch 2
Advisory 2
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-24871 · CVE Program
- CVE-2022-24871 · NVD
- FIRST EPSS
- GHSA-7gm7-8q8v-9gf2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences