Read the docs
TI-2022-08683 Aliases CVE-2022-24872GHSA-9wrv-g75h-8ccc

Improper Access Control in shopware

Priority LOW 39CWE-732Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

Shopware is an open commerce platform based on Symfony Framework and Vue. Permissions set to sales channel context by admin-api are still usable within normal user session. Users are advised to update to the current version 6.4.10.1. For older versions of 6.1, 6.2, and 6.3, corresponding security measures are also available via a plugin. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01052 64th percentileScored 2026-11-07
Fix Fixed platform (shopware): 6.4.10.1shopware/platform (Packagist): 6.4.10.1+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareplatformbefore 6.4.10.16.4.10.1Patch availableCNA
—shopware/platform (Packagist)before 6.4.10.16.4.10.1Patch availableGHSA-9wrv-g75h-8ccc
—shopware/core (Packagist)before 6.4.10.16.4.10.1Patch availableGHSA-9wrv-g75h-8ccc
  • platform Vendorshopware Affected before 6.4.10.1 Fixed in 6.4.10.1 Patch available CNA
  • shopware/platform (Packagist) Vendor— Affected before 6.4.10.1 Fixed in 6.4.10.1 Patch available GHSA-9wrv-g75h-8ccc
  • shopware/core (Packagist) Vendor— Affected before 6.4.10.1 Fixed in 6.4.10.1 Patch available GHSA-9wrv-g75h-8ccc

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*before 6.4.10.1Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions before 6.4.10.1 Vulnerable ·shopware

Remediation

  • Fix · CNA platform (shopware) Fixed in 6.4.10.1
  • Fix · GHSA-9wrv-g75h-8ccc shopware/platform (Packagist) Fixed in 6.4.10.1 Advisory →
  • Fix · GHSA-9wrv-g75h-8ccc shopware/core (Packagist) Fixed in 6.4.10.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24872
  2. 2026-10-03 Alias added: GHSA-9wrv-g75h-8ccc

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources