Non-Stored Cross-site Scripting in Shopware storefront
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Shopware is an open source e-commerce software platform. Prior to version 5.7.9, Shopware is vulnerable to non-stored cross-site scripting in the storefront. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00791 56th percentileScored 2026-11-07
Fix Fixed shopware (shopware): 5.7.9shopware/shopware (Packagist): 5.7.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| shopware | shopware | before 5.7.9 | 5.7.9 | Patch available | CNA |
| — | shopware/shopware (Packagist) | before 5.7.9 | 5.7.9 | Patch available | GHSA-4g29-fccr-p59w |
- shopware Vendorshopware Affected before 5.7.9 Fixed in 5.7.9 Patch available CNA
- shopware/shopware (Packagist) Vendor— Affected before 5.7.9 Fixed in 5.7.9 Patch available GHSA-4g29-fccr-p59w
Remediation
- Fix · CNA shopware (shopware) Fixed in 5.7.9
- Fix · GHSA-4g29-fccr-p59w shopware/shopware (Packagist) Fixed in 5.7.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24873
- 2026-10-03 Alias added: GHSA-4g29-fccr-p59w
References
Advisory 4
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-24873 · CVE Program
- CVE-2022-24873 · NVD
- FIRST EPSS
- GHSA-4g29-fccr-p59w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences