Read the docs
TI-2022-08689 Aliases CVE-2022-24879GHSA-pf38-v6qj-j23h

Malfunction of Cross-Site Request Forgery token validation

Priority MEDIUM 40CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-352.

Summary

Shopware is an open source e-commerce software platform. Versions prior to 5.7.9 are vulnerable to malfunction of cross-site request forgery (CSRF) token validation. Under certain circumstances, the CSRF tokens were not generated anew and not validated correctly. This issue is fixed in version 5.7.9. Users of older versions may attempt to mitigate the vulnerability by using the Shopware security plugin.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00605 49th percentileScored 2026-11-07
Fix Fixed shopware (shopware): 5.7.9shopware/shopware (Packagist): 5.7.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopware5.2.0 to before 5.7.95.7.9Patch availableCNA
—shopware/shopware (Packagist)5.2.0 to before 5.7.95.7.9Patch availableGHSA-pf38-v6qj-j23h
  • shopware Vendorshopware Affected 5.2.0 to before 5.7.9 Fixed in 5.7.9 Patch available CNA
  • shopware/shopware (Packagist) Vendor— Affected 5.2.0 to before 5.7.9 Fixed in 5.7.9 Patch available GHSA-pf38-v6qj-j23h

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*5.2.0 to before 5.7.9Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions 5.2.0 to before 5.7.9 Vulnerable ·shopware

Remediation

  • Fix · CNA shopware (shopware) Fixed in 5.7.9
  • Fix · GHSA-pf38-v6qj-j23h shopware/shopware (Packagist) Fixed in 5.7.9 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24879
  2. 2026-10-03 Alias added: GHSA-pf38-v6qj-j23h

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources