Read the docs
TI-2022-08880 Aliases CVE-2022-25167GHSA-x5m7-rwfx-w7qm

Apache Flume vulnerable to a JNDI RCE in JMSSource

Priority MEDIUM 50CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Apache Flume versions 1.4.0 through 1.9.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Why it matters now

EPSS 0.05397 92nd percentileScored 2026-11-07
Fix Fixed Apache Flume (Apache Software Foundation): 1.10.0org.apache.flume.flume-ng-sources:flume-jms-source (Maven): 1.10.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Flumeflume-jms-source to before 1.10.01.10.0Patch availableCNA
—org.apache.flume.flume-ng-sources:flume-jms-source (Maven)1.4.0 to before 1.10.01.10.0Patch availableGHSA-x5m7-rwfx-w7qm
  • Apache Flume VendorApache Affected flume-jms-source to before 1.10.0 Fixed in 1.10.0 Patch available CNA
  • org.apache.flume.flume-ng-sources:flume-jms-source (Maven) Vendor— Affected 1.4.0 to before 1.10.0 Fixed in 1.10.0 Patch available GHSA-x5m7-rwfx-w7qm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:flume:*:*:*:*:*:*:*:*1.4.0 to before 1.10.0VulnerableApache
  • cpe:2.3:a:apache:flume:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.10.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Flume (Apache Software Foundation) Fixed in 1.10.0
  • Fix · GHSA-x5m7-rwfx-w7qm org.apache.flume.flume-ng-sources:flume-jms-source (Maven) Fixed in 1.10.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-25167
  2. 2026-10-03 Alias added: GHSA-x5m7-rwfx-w7qm

References

  • TI-2022-20667 Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource CVSS 3.1CRITICAL 9.8
  • TI-2022-15705 Improper Input Validation (JNDI Injection) in JMSMessageConsumer CVSS 3.1CRITICAL 9.8

Sources