Read the docs
TI-2022-15705 Aliases CVE-2022-34916GHSA-h9mh-mgpv-gqmv

Improper Input Validation (JNDI Injection) in JMSMessageConsumer

Priority MEDIUM 48CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Apache Flume versions 1.4.0 through 1.10.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Why it matters now

EPSS 0.03028 87th percentileScored 2026-11-07
Fix Fixed Apache Flume (Apache Software Foundation): 1.11.0org.apache.flume.flume-ng-sources:flume-jms-source (Maven): 1.10.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Flumeflume-jms-source to before 1.11.01.11.0Patch availableCNA
—org.apache.flume.flume-ng-sources:flume-jms-source (Maven)1.4.0 to before 1.10.11.10.1Patch availableGHSA-h9mh-mgpv-gqmv
  • Apache Flume VendorApache Affected flume-jms-source to before 1.11.0 Fixed in 1.11.0 Patch available CNA
  • org.apache.flume.flume-ng-sources:flume-jms-source (Maven) Vendor— Affected 1.4.0 to before 1.10.1 Fixed in 1.10.1 Patch available GHSA-h9mh-mgpv-gqmv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:flume:*:*:*:*:*:*:*:*1.4.0 to before 1.10.1VulnerableApache
  • cpe:2.3:a:apache:flume:*:*:*:*:*:*:*:* Versions 1.4.0 to before 1.10.1 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Flume (Apache Software Foundation) Fixed in 1.11.0
  • Fix · GHSA-h9mh-mgpv-gqmv org.apache.flume.flume-ng-sources:flume-jms-source (Maven) Fixed in 1.10.1 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 6 products
  • A-MQ Clients 2
  • Red Hat Data Grid 8
  • Red Hat JBoss Data Grid 7
  • Red Hat JBoss Enterprise Application Platform 7
  • Red Hat JBoss Enterprise Application Platform Expansion Pack
  • streams for Apache Kafka

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-34916
  2. 2026-10-03 Alias added: GHSA-h9mh-mgpv-gqmv

References

  • TI-2022-20667 Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource CVSS 3.1CRITICAL 9.8
  • TI-2022-08880 Apache Flume vulnerable to a JNDI RCE in JMSSource CVSS 3.1CRITICAL 9.8

Sources