Read the docs
TI-2022-20667 Aliases CVE-2022-42468GHSA-9w4g-fp9h-3q2v

Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource

Priority MEDIUM 55CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.03722 89th percentileScored 2026-11-07
Fix Fixed Apache Flume (Apache Software Foundation): 1.11.0org.apache.flume.flume-ng-sources:flume-jms-source (Maven): 1.11.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache FlumeFlume JMSSource to before 1.11.01.11.0Patch availableCNA
—org.apache.flume.flume-ng-sources:flume-jms-source (Maven)before 1.11.01.11.0Patch availableGHSA-9w4g-fp9h-3q2v
  • Apache Flume VendorApache Affected Flume JMSSource to before 1.11.0 Fixed in 1.11.0 Patch available CNA
  • org.apache.flume.flume-ng-sources:flume-jms-source (Maven) Vendor— Affected before 1.11.0 Fixed in 1.11.0 Patch available GHSA-9w4g-fp9h-3q2v

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:flume:*:*:*:*:*:*:*:*1.4.0 – 1.10.1VulnerableApache
  • cpe:2.3:a:apache:flume:*:*:*:*:*:*:*:* Versions 1.4.0 – 1.10.1 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Flume (Apache Software Foundation) Fixed in 1.11.0
  • Fix · GHSA-9w4g-fp9h-3q2v org.apache.flume.flume-ng-sources:flume-jms-source (Maven) Fixed in 1.11.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-42468
  2. 2026-10-03 Alias added: GHSA-9w4g-fp9h-3q2v

References

  • TI-2022-08880 Apache Flume vulnerable to a JNDI RCE in JMSSource CVSS 3.1CRITICAL 9.8
  • TI-2022-15705 Improper Input Validation (JNDI Injection) in JMSMessageConsumer CVSS 3.1CRITICAL 9.8

Sources