Server-Side Request Forgery in Asset section
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Prior to the patched version, an authenticated user of Mautic could read system files and access the internal addresses of the application due to a Server-Side Request Forgery (SSRF) vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | >= 1.0.0-beta4 to before < 4.4.12; > 5.0.0 to before < 5.0.4 | < 4.4.12, < 5.0.4 | Patch available | CNA |
| — | mautic/core (Packagist) | 1.0.0-beta4 to before 4.4.12 | 4.4.12 | Patch available | GHSA-mgv8-w49f-822w |
| — | mautic/core (Packagist) | 5.0.0-alpha to before 5.0.4 | 5.0.4 | Patch available | GHSA-mgv8-w49f-822w |
- Mautic VendorMautic Affected >= 1.0.0-beta4 to before < 4.4.12; > 5.0.0 to before < 5.0.4 Fixed in < 4.4.12, < 5.0.4 Patch available CNA
- mautic/core (Packagist) Vendor— Affected 1.0.0-beta4 to before 4.4.12 Fixed in 4.4.12 Patch available GHSA-mgv8-w49f-822w
- mautic/core (Packagist) Vendor— Affected 5.0.0-alpha to before 5.0.4 Fixed in 5.0.4 Patch available GHSA-mgv8-w49f-822w
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* | 1.0.1 to before 4.4.12; 5.0.0 to before 5.0.4 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:-:*:*:*:*:*:* | 1.0.0 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:beta4:*:*:*:*:*:* | 1.0.0 beta4 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc1:*:*:*:*:*:* | 1.0.0 rc1 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc2:*:*:*:*:*:* | 1.0.0 rc2 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc3:*:*:*:*:*:* | 1.0.0 rc3 | Vulnerable | Acquia |
| cpe:2.3:a:acquia:mautic:1.0.0:rc4:*:*:*:*:*:* | 1.0.0 rc4 | Vulnerable | Acquia |
- cpe:2.3:a:acquia:mautic:*:*:*:*:*:*:*:* Versions 1.0.1 to before 4.4.12; 5.0.0 to before 5.0.4 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:-:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:beta4:*:*:*:*:*:* Versions 1.0.0 beta4 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc1:*:*:*:*:*:* Versions 1.0.0 rc1 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc2:*:*:*:*:*:* Versions 1.0.0 rc2 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc3:*:*:*:*:*:* Versions 1.0.0 rc3 Vulnerable ·Acquia
- cpe:2.3:a:acquia:mautic:1.0.0:rc4:*:*:*:*:*:* Versions 1.0.0 rc4 Vulnerable ·Acquia
Remediation
- Fix · CNA Mautic (Mautic) Fixed in < 4.4.12, < 5.0.4
- Fix · GHSA-mgv8-w49f-822w mautic/core (Packagist) Fixed in 4.4.12 Advisory →
- Fix · GHSA-mgv8-w49f-822w mautic/core (Packagist) Fixed in 5.0.4 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Mautic < 4.4.12, < 5.0.4
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-09348 Sensitive Data Exposure due to inadequate user permission settingsPriority LOW 36
- TI-2022-09347 SQL Injection in dynamic ReportsPriority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25777
- 2026-10-03 Alias added: GHSA-mgv8-w49f-822w
References
Advisory 2
More Mautic vulnerabilities
- TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2022-25777 · CVE Program
- CVE-2022-25777 · NVD
- FIRST EPSS
- GHSA-mgv8-w49f-822w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences