Cross-site scripting in Dell PowerStore
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Dell PowerStore Versions before v2.1.1.0. contains a Stored Cross-Site Scripting vulnerability. A high privileged network attacker could potentially exploit this vulnerability, leading to the storage of malicious HTML or JavaScript codes in a trusted application data store. When a victim user accesses the data store through their browsers, the malicious code gets executed by the web browser in the context of the vulnerable web application. Exploitation may lead to information disclosure, session theft, or client-side request forgery.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA PowerStore (Dell) Fixed in PowerStore SW v2.1.1.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell PowerStore PowerStore SW v2.1.1.0
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-10111 CSV injection in Dell PowerStorePriority LOW 36
- TI-2022-10112 OS command injection in Dell PowerStorePriority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2022-26866
- 2026-10-03 Alias added: GHSA-7h6f-6j9m-8x6g
References
More Dell Powerstoreos vulnerabilities
- TI-2026-42160 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 9.8
- TI-2022-10113 Information disclosure in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55184 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 10.0
- TI-2022-10114 Authentication bypass in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55183 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
- TI-2026-55181 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
Sources
- CVE-2022-26866 · CVE Program
- CVE-2022-26866 · NVD
- FIRST EPSS
- GHSA-7h6f-6j9m-8x6g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences