OS command injection in Dell PowerStore
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
Dell EMC PowerStore versions 2.0.0.x, 2.0.1.x, and 2.1.0.x are vulnerable to a command injection flaw. An authenticated attacker could potentially exploit this vulnerability, leading to the execution of arbitrary OS commands on the application's underlying OS, with the privileges of the vulnerable application. Exploitation may lead to a system takeover by an attacker.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell | PowerStore | before PowerStore SW v2.1.1.0 | PowerStore SW v2.1.1.0 | Patch available | CNA |
- PowerStore VendorDell Affected before PowerStore SW v2.1.1.0 Fixed in PowerStore SW v2.1.1.0 Patch available CNA
Remediation
- Fix · CNA PowerStore (Dell) Fixed in PowerStore SW v2.1.1.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell PowerStore PowerStore SW v2.1.1.0
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2022-10111 CSV injection in Dell PowerStorePriority LOW 36
- TI-2022-10110 Cross-site scripting in Dell PowerStorePriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2022-26868
- 2026-10-03 Alias added: GHSA-x9m9-3xvj-c28p
References
More Dell Powerstoreos vulnerabilities
- TI-2026-42160 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 9.8
- TI-2022-10113 Information disclosure in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55184 Missing authentication in Dell PowerStore 500T CVSS 3.1CRITICAL 10.0
- TI-2022-10114 Authentication bypass in Dell PowerStore CVSS 3.1CRITICAL 9.8
- TI-2026-55183 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
- TI-2026-55181 Protection mechanism failure in Dell PowerStore 500T CVSS 3.1HIGH 8.8
Sources
- CVE-2022-26868 · CVE Program
- CVE-2022-26868 · NVD
- FIRST EPSS
- GHSA-x9m9-3xvj-c28p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences