Read the docs
TI-2022-11607 Aliases CVE-2022-29041GHSA-m3p3-2gp6-ghq8

Cross-site scripting in Jenkins Jira Plugin

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Why it matters now

EPSS 0.00855 58th percentileScored 2026-11-07
Fix Fixed Jenkins Jira Plugin (Jenkins project): 3.6.1org.jenkins-ci.plugins:jira (Maven): 3.7.1, 3.6.1Red Hat: 2 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
JenkinsJenkins Jira Pluginup to 3.73.6.1Patch availableCNA
—org.jenkins-ci.plugins:jira (Maven)3.7.0 to before 3.7.13.7.1Patch availableGHSA-m3p3-2gp6-ghq8
—org.jenkins-ci.plugins:jira (Maven)before 3.6.13.6.1Patch availableGHSA-m3p3-2gp6-ghq8
  • Jenkins Jira Plugin VendorJenkins Affected up to 3.7 Fixed in 3.6.1 Patch available CNA
  • org.jenkins-ci.plugins:jira (Maven) Vendor— Affected 3.7.0 to before 3.7.1 Fixed in 3.7.1 Patch available GHSA-m3p3-2gp6-ghq8
  • org.jenkins-ci.plugins:jira (Maven) Vendor— Affected before 3.6.1 Fixed in 3.6.1 Patch available GHSA-m3p3-2gp6-ghq8

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:jira:*:*:*:*:*:jenkins:*:*before 3.6.1VulnerableJenkins
cpe:2.3:a:jenkins:jira:3.7:*:*:*:*:*:*:*3.7VulnerableJenkins
  • cpe:2.3:a:jenkins:jira:*:*:*:*:*:jenkins:*:* Versions before 3.6.1 Vulnerable ·Jenkins
  • cpe:2.3:a:jenkins:jira:3.7:*:*:*:*:*:*:* Versions 3.7 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins Jira Plugin (Jenkins project) Fixed in 3.6.1
  • Fix · GHSA-m3p3-2gp6-ghq8 org.jenkins-ci.plugins:jira (Maven) Fixed in 3.7.1 Advisory →
  • Fix · GHSA-m3p3-2gp6-ghq8 org.jenkins-ci.plugins:jira (Maven) Fixed in 3.6.1 Advisory →

Red Hat 2 advisories

  • RHSA-2022:2205 Released 2022-05-18 · Red Hat rating Important
    OpenShift Container Platform 4.9.33 packages and security update
    • Red Hat OpenShift Container Platform 4.9 jenkins-2-plugins-4.9.1651754460-1.el8
  • RHSA-2022:1600 Released 2022-05-02 · Red Hat rating Moderate
    OpenShift Container Platform 4.10.12 security update
    • Red Hat OpenShift Container Platform 4.10 cri-o-1.23.2-8.rhaos4.10.git8ad5d25.el8, jenkins-2-plugins-4.10.1650890594-1.el8

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift Container Platform 4.10Fixed RHSA-2022:1600
Red Hat OpenShift Container Platform 4.9Fixed RHSA-2022:2205
Not affected: 3 products
  • Red Hat OpenShift Container Platform 3.11
  • Red Hat OpenShift Container Platform 4.10
  • Red Hat OpenShift Container Platform 4.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-29041
  2. 2026-10-03 Alias added: GHSA-m3p3-2gp6-ghq8

References

  • TI-2019-12403 Exposure of resource to wrong sphere in Jenkins JIRA Plugin CVSS 3.1CRITICAL 9.9
  • TI-2023-27120 Cross-site request forgery in Jenkins NeuVector Vulnerability Scanner Plugin CVSS 3.1HIGH 8.8
  • TI-2018-15885 An improper authorization vulnerability exists in Jenkins Jira Plugin 3.0.1 and earlier… CVSS 3.1HIGH 8.8
  • TI-2023-27112 Insufficiently protected credentials in Jenkins Jira Plugin CVSS 3.1MEDIUM 6.5

Sources