Insufficiently protected credentials in Jenkins Jira Plugin
Priority LOW 30CWE-522Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.
Summary
Jenkins Jira Plugin 3.11 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure permission to access and capture credentials they are not entitled to.
Why it matters now
EPSS 0.0061 49th percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:jira (Maven): 3.12
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Jira Plugin | up to 3.11 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:jira (Maven) | before 3.12 | 3.12 | Patch available | GHSA-qmhq-876f-cr65 |
- Jenkins Jira Plugin VendorJenkins Affected up to 3.11 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:jira (Maven) Vendor— Affected before 3.12 Fixed in 3.12 Patch available GHSA-qmhq-876f-cr65
Remediation
- Fix · GHSA-qmhq-876f-cr65 org.jenkins-ci.plugins:jira (Maven) Fixed in 3.12 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-49653
- 2026-10-03 Alias added: GHSA-qmhq-876f-cr65
References
More Jenkins Jira vulnerabilities
- TI-2019-12403 Exposure of resource to wrong sphere in Jenkins JIRA Plugin CVSS 3.1CRITICAL 9.9
- TI-2023-27120 Cross-site request forgery in Jenkins NeuVector Vulnerability Scanner Plugin CVSS 3.1HIGH 8.8
- TI-2018-15885 An improper authorization vulnerability exists in Jenkins Jira Plugin 3.0.1 and earlier… CVSS 3.1HIGH 8.8
- TI-2022-11607 Cross-site scripting in Jenkins Jira Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-49653 · CVE Program
- CVE-2023-49653 · NVD
- FIRST EPSS
- GHSA-qmhq-876f-cr65 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences