Integer overflow in `SpaceToBatchND` in TensorFlow
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.
Summary
TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SpaceToBatchND` (in all backends such as XLA and handwritten kernels) is vulnerable to an integer overflow: The result of this integer overflow is used to allocate the output tensor, hence we get a denial of service via a `CHECK`-failure (assertion failure), as in TFSA-2021-198. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.6.4; 2.7.0rc0 to before 2.7.2; 2.8.0rc0 to before 2.8.1; 2.9.0rc0 to before 2.9.0 | 2.6.4, 2.7.2, 2.8.1, 2.9.0 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.6.4 | 2.6.4 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow (PyPI) | 2.7.0 to before 2.7.2 | 2.7.2 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow-cpu (PyPI) | before 2.6.4 | 2.6.4 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow-cpu (PyPI) | 2.7.0 to before 2.7.2 | 2.7.2 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow-cpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow-gpu (PyPI) | before 2.6.4 | 2.6.4 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow-gpu (PyPI) | 2.7.0 to before 2.7.2 | 2.7.2 | Patch available | GHSA-jjm6-4vf7-cjh4 |
| — | tensorflow-gpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-jjm6-4vf7-cjh4 |
- tensorflow VendorGoogle Affected before 2.6.4; 2.7.0rc0 to before 2.7.2; 2.8.0rc0 to before 2.8.1; 2.9.0rc0 to before 2.9.0 Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow-cpu (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow-cpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow-gpu (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow-gpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-jjm6-4vf7-cjh4
- tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-jjm6-4vf7-cjh4
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 2.6.4; 2.7.0 to before 2.7.2 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* | 2.7.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* | 2.7.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.8.0:-:*:*:*:*:*:* | 2.8.0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.8.0:rc0:*:*:*:*:*:* | 2.8.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.8.0:rc1:*:*:*:*:*:* | 2.8.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.9.0:rc0:*:*:*:*:*:* | 2.9.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.9.0:rc1:*:*:*:*:*:* | 2.9.0 rc1 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.6.4; 2.7.0 to before 2.7.2 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.8.0:-:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.8.0:rc0:*:*:*:*:*:* Versions 2.8.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.8.0:rc1:*:*:*:*:*:* Versions 2.8.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.9.0:rc0:*:*:*:*:*:* Versions 2.9.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.9.0:rc1:*:*:*:*:*:* Versions 2.9.0 rc1 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow (PyPI) Fixed in 2.6.4 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow-cpu (PyPI) Fixed in 2.6.4 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow-cpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow-gpu (PyPI) Fixed in 2.6.4 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow-gpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-jjm6-4vf7-cjh4 tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29203
- 2026-10-03 Alias added: GHSA-jjm6-4vf7-cjh4
References
Patch 2
Advisory 5
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2022-29203 · CVE Program
- CVE-2022-29203 · NVD
- FIRST EPSS
- GHSA-jjm6-4vf7-cjh4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences