Read the docs
TI-2022-11750 Aliases CVE-2022-29207GHSA-5wpj-c6f7-24x8

Undefined behavior when users supply invalid resource handles in TensorFlow

Priority MEDIUM 58CWE-20Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, multiple TensorFlow operations misbehave in eager mode when the resource handle provided to them is invalid. In graph mode, it would have been impossible to perform these API calls, but migration to TF 2.x eager mode opened up this vulnerability. If the resource handle is empty, then a reference is bound to a null pointer inside TensorFlow codebase (various codepaths). This is undefined behavior. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00325 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.6.4, 2.7.2, 2.8.1 +1tensorflow (PyPI): 2.6.4, 2.7.2, 2.8.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflowbefore 2.6.4; 2.7.0rc0 to before 2.7.2; 2.8.0rc0 to before 2.8.1; 2.9.0rc0 to before 2.9.02.6.4, 2.7.2, 2.8.1, 2.9.0Patch availableCNA
—tensorflow (PyPI)before 2.6.42.6.4Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow (PyPI)2.7.0 to before 2.7.22.7.2Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow-cpu (PyPI)before 2.6.42.6.4Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow-cpu (PyPI)2.7.0 to before 2.7.22.7.2Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow-cpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow-gpu (PyPI)before 2.6.42.6.4Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow-gpu (PyPI)2.7.0 to before 2.7.22.7.2Patch availableGHSA-5wpj-c6f7-24x8
—tensorflow-gpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-5wpj-c6f7-24x8
  • tensorflow VendorGoogle Affected before 2.6.4; 2.7.0rc0 to before 2.7.2; 2.8.0rc0 to before 2.8.1; 2.9.0rc0 to before 2.9.0 Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow-cpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow-gpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-5wpj-c6f7-24x8
  • tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-5wpj-c6f7-24x8

CPE configurations NVD · 8

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*before 2.6.4; 2.7.0 to before 2.7.2VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:*2.7.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:*2.7.0 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.8.0:-:*:*:*:*:*:*2.8.0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.8.0:rc0:*:*:*:*:*:*2.8.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.8.0:rc1:*:*:*:*:*:*2.8.0 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.9.0:rc0:*:*:*:*:*:*2.9.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.9.0:rc1:*:*:*:*:*:*2.9.0 rc1VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.6.4; 2.7.0 to before 2.7.2 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.8.0:-:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.8.0:rc0:*:*:*:*:*:* Versions 2.8.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.8.0:rc1:*:*:*:*:*:* Versions 2.8.0 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.9.0:rc0:*:*:*:*:*:* Versions 2.9.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.9.0:rc1:*:*:*:*:*:* Versions 2.9.0 rc1 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow (PyPI) Fixed in 2.6.4 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow-cpu (PyPI) Fixed in 2.6.4 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow-cpu (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow-gpu (PyPI) Fixed in 2.6.4 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow-gpu (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-5wpj-c6f7-24x8 tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-29207
  2. 2026-10-03 Alias added: GHSA-5wpj-c6f7-24x8

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources