Type confusion leading to `CHECK`-failure based denial of service in TensorFlow
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-843 and the CVSS impact.
Summary
TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the macros that TensorFlow uses for writing assertions (e.g., `CHECK_LT`, `CHECK_GT`, etc.) have an incorrect logic when comparing `size_t` and `int` values. Due to type conversion rules, several of the macros would trigger incorrectly. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.6.4; 2.7.0rc0 to before 2.7.2; 2.8.0rc0 to before 2.8.1; 2.9.0rc0 to before 2.9.0 | 2.6.4, 2.7.2, 2.8.1, 2.9.0 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.6.4 | 2.6.4 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow (PyPI) | 2.7.0 to before 2.7.2 | 2.7.2 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow-cpu (PyPI) | before 2.6.4 | 2.6.4 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow-cpu (PyPI) | 2.7.0 to before 2.7.2 | 2.7.2 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow-cpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow-gpu (PyPI) | before 2.6.4 | 2.6.4 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow-gpu (PyPI) | 2.7.0 to before 2.7.2 | 2.7.2 | Patch available | GHSA-f4rr-5m7v-wxcw |
| — | tensorflow-gpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-f4rr-5m7v-wxcw |
- tensorflow VendorGoogle Affected before 2.6.4; 2.7.0rc0 to before 2.7.2; 2.8.0rc0 to before 2.8.1; 2.9.0rc0 to before 2.9.0 Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow-cpu (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow-cpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow-gpu (PyPI) Vendor— Affected before 2.6.4 Fixed in 2.6.4 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow-gpu (PyPI) Vendor— Affected 2.7.0 to before 2.7.2 Fixed in 2.7.2 Patch available GHSA-f4rr-5m7v-wxcw
- tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-f4rr-5m7v-wxcw
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 2.6.4; 2.7.0 to before 2.7.2 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* | 2.7.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* | 2.7.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.8.0:-:*:*:*:*:*:* | 2.8.0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.8.0:rc0:*:*:*:*:*:* | 2.8.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.8.0:rc1:*:*:*:*:*:* | 2.8.0 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.9.0:rc0:*:*:*:*:*:* | 2.9.0 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.9.0:rc1:*:*:*:*:*:* | 2.9.0 rc1 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.6.4; 2.7.0 to before 2.7.2 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc0:*:*:*:*:*:* Versions 2.7.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.7.0:rc1:*:*:*:*:*:* Versions 2.7.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.8.0:-:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.8.0:rc0:*:*:*:*:*:* Versions 2.8.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.8.0:rc1:*:*:*:*:*:* Versions 2.8.0 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.9.0:rc0:*:*:*:*:*:* Versions 2.9.0 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.9.0:rc1:*:*:*:*:*:* Versions 2.9.0 rc1 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.6.4, 2.7.2, 2.8.1, 2.9.0
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow (PyPI) Fixed in 2.6.4 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow-cpu (PyPI) Fixed in 2.6.4 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow-cpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow-gpu (PyPI) Fixed in 2.6.4 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow-gpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-f4rr-5m7v-wxcw tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29209
- 2026-10-03 Alias added: GHSA-f4rr-5m7v-wxcw
References
Exploit 3
Advisory 6
- https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4
- https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2
- https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1
- https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0
- https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/platform/default/logging.h
- https://nvd.nist.gov/vuln/detail/CVE-2022-29209
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2022-29209 · CVE Program
- CVE-2022-29209 · NVD
- FIRST EPSS
- GHSA-f4rr-5m7v-wxcw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences