Remote denial of service in Hyperledger Fabric Gateway
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| hyperledger | fabric | before 2.4.6 | 2.4.6 | Patch available | CNA |
| — | github.com/hyperledger/fabric (Go) | 2.4.0 to before 2.4.6 | 2.4.6 | Patch available | GHSA-qj6r-fhrc-jj5r |
- fabric Vendorhyperledger Affected before 2.4.6 Fixed in 2.4.6 Patch available CNA
- github.com/hyperledger/fabric (Go) Vendor— Affected 2.4.0 to before 2.4.6 Fixed in 2.4.6 Patch available GHSA-qj6r-fhrc-jj5r
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:* | before 2.4.6 | Vulnerable | hyperledger |
- cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:* Versions before 2.4.6 Vulnerable ·hyperledger
Remediation
- Fix · CNA fabric (hyperledger) Fixed in 2.4.6
- Fix · GHSA-qj6r-fhrc-jj5r github.com/hyperledger/fabric (Go) Fixed in 2.4.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36023
- 2026-10-03 Alias added: GHSA-qj6r-fhrc-jj5r
References
Patch 3
Advisory 2
More hyperledger Fabric vulnerabilities
- TI-2026-30139 ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE CVSS 4.0CRITICAL 9.3
- TI-2022-13165 Improper Input Validation in fabric hyperledger CVSS 3.1HIGH 7.5
- TI-2022-22261 Hyperledger Fabric 2.3 allows attackers to cause a denial of service (orderer crash) by… CVSS 3.1HIGH 7.5
- TI-2023-24774 Crosslinking transaction attack in hyperledger/fabric CVSS 3.1HIGH 7.1
- TI-2024-30320 Hyperledger Fabric through 3.0.0 and 2.5.x through 2.5.9 do not verify that a request has… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-36023 · CVE Program
- CVE-2022-36023 · NVD
- FIRST EPSS
- GHSA-qj6r-fhrc-jj5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences