Crosslinking transaction attack in hyperledger/fabric
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Hyperledger Fabric is an open source permissioned distributed ledger framework. Combining two molecules to one another, called "cross-linking" results in a molecule with a chemical formula that is composed of all atoms of the original two molecules. In Fabric, one can take a block of transactions and cross-link the transactions in a way that alters the way the peers parse the transactions. If a first peer receives a block B and a second peer receives a block identical to B but with the transactions being cross-linked, the second peer will parse transactions in a different way and thus its world state will deviate from the first peer. Orderers or peers cannot detect that a block has its transactions cross-linked, because there is a vulnerability in the way Fabric hashes the transactions of blocks. It simply and naively concatenates them, which is insecure and lets an adversary craft a "cross-linked block" (block with cross-linked transactions) which alters the way peers process transactions. For example, it is possible to select a transaction and manipulate a peer to completely avoid processing it, without changing the computed hash of the block. Additional validations have been added in v2.2.14 and v2.5.5 to detect potential cross-linking issues before processing blocks. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| hyperledger | fabric | 1.0.0 to before 2.2.14; 2.3.0 to before 2.5.5 | 2.2.14, 2.5.5 | Patch available | CNA |
| — | github.com/hyperledger/fabric (Go) | 1.0.0-alpha to before 2.2.14 | 2.2.14 | Patch available | GHSA-v9w2-543f-h69m |
| — | github.com/hyperledger/fabric (Go) | 2.3.0 to before 2.5.5 | 2.5.5 | Patch available | GHSA-v9w2-543f-h69m |
- fabric Vendorhyperledger Affected 1.0.0 to before 2.2.14; 2.3.0 to before 2.5.5 Fixed in 2.2.14, 2.5.5 Patch available CNA
- github.com/hyperledger/fabric (Go) Vendor— Affected 1.0.0-alpha to before 2.2.14 Fixed in 2.2.14 Patch available GHSA-v9w2-543f-h69m
- github.com/hyperledger/fabric (Go) Vendor— Affected 2.3.0 to before 2.5.5 Fixed in 2.5.5 Patch available GHSA-v9w2-543f-h69m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:* | 1.0.0 to before 2.2.14; 2.3.0 to before 2.5.5 | Vulnerable | hyperledger |
- cpe:2.3:a:hyperledger:fabric:*:*:*:*:*:*:*:* Versions 1.0.0 to before 2.2.14; 2.3.0 to before 2.5.5 Vulnerable ·hyperledger
Remediation
- Fix · CNA fabric (hyperledger) Fixed in 2.2.14, 2.5.5
- Fix · GHSA-v9w2-543f-h69m github.com/hyperledger/fabric (Go) Fixed in 2.2.14 Advisory →
- Fix · GHSA-v9w2-543f-h69m github.com/hyperledger/fabric (Go) Fixed in 2.5.5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46132
- 2026-10-03 Alias added: GHSA-v9w2-543f-h69m
References
Other 7
- https://github.com/hyperledger/fabric/pull/4503
- https://github.com/hyperledger/fabric/pull/4504
- https://github.com/hyperledger/fabric/commit/389b2e66de9a6fbc6043216d554c97bbbdf0e008
- https://github.com/hyperledger/fabric/commit/93bef10bd3ce3c54d7f3b064f765dbde61da7def
- https://github.com/hyperledger/fabric
- https://github.com/hyperledger/fabric/releases/tag/v2.2.14
- https://github.com/hyperledger/fabric/releases/tag/v2.5.5
More hyperledger Fabric vulnerabilities
- TI-2026-30139 ObjectInputStream.readObject() without ObjectInputFilter in fabric-sdk-java allows Java deserialization RCE CVSS 4.0CRITICAL 9.3
- TI-2022-13165 Improper Input Validation in fabric hyperledger CVSS 3.1HIGH 7.5
- TI-2022-22261 Hyperledger Fabric 2.3 allows attackers to cause a denial of service (orderer crash) by… CVSS 3.1HIGH 7.5
- TI-2022-16448 Remote denial of service in Hyperledger Fabric Gateway CVSS 3.1HIGH 7.0
- TI-2024-30320 Hyperledger Fabric through 3.0.0 and 2.5.x through 2.5.9 do not verify that a request has… CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-46132 · CVE Program
- CVE-2023-46132 · NVD
- FIRST EPSS
- GHSA-v9w2-543f-h69m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences