Read the docs
TI-2022-13191 Aliases CVE-2022-31148GHSA-5834-xv5q-cgfw

Persistent cross site scripting in customer module in Shopware

Priority LOW 26CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00693 53rd percentileScored 2026-11-07
Fix Fixed shopware (shopware): 5.7.14shopware/shopware (Packagist): 5.7.14

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shopwareshopware5.7.0 to before 5.7.145.7.14Patch availableCNA
—shopware/shopware (Packagist)5.7.0 to before 5.7.145.7.14Patch availableGHSA-5834-xv5q-cgfw
  • shopware Vendorshopware Affected 5.7.0 to before 5.7.14 Fixed in 5.7.14 Patch available CNA
  • shopware/shopware (Packagist) Vendor— Affected 5.7.0 to before 5.7.14 Fixed in 5.7.14 Patch available GHSA-5834-xv5q-cgfw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:*5.7.0 to before 5.7.14Vulnerableshopware
  • cpe:2.3:a:shopware:shopware:*:*:*:*:*:*:*:* Versions 5.7.0 to before 5.7.14 Vulnerable ·shopware

Remediation

  • Fix · CNA shopware (shopware) Fixed in 5.7.14
  • Fix · GHSA-5834-xv5q-cgfw shopware/shopware (Packagist) Fixed in 5.7.14 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-31148
  2. 2026-10-03 Alias added: GHSA-5834-xv5q-cgfw

References

  • TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
  • TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
  • TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
  • TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
  • TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
  • TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
See all 66 →

Sources