Improper access control in NodeJS Node
Priority MEDIUM 45CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-284 and CWE-78.
Summary
A OS Command Injection vulnerability exists in Node.js versions <14.20.0, <16.20.0, <18.5.0 due to an insufficient IsAllowedHost check that can easily be bypassed because IsIPAddress does not properly check if an IP address is invalid before making DBS requests allowing rebinding attacks.
Why it matters now
EPSS 0.06432 93rd percentileScored 2026-11-07
Fix Fixed Node (NodeJS): 14.20.1, 16.17.1, 18.9.1Red Hat: 5 advisories
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NodeJS | Node | 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 to before 14.20.1; 15.0 and later; 16.0 to before 16.17.1; 17.0 and later; 18.0 to before 18.9.1 | 14.20.1, 16.17.1, 18.9.1 | Patch available | CNA |
- Node VendorNodeJS Affected 4.0 and later; 5.0 and later; 6.0 and later; 7.0 and later; 8.0 and later; 9.0 and later; 10.0 and later; 11.0 and later; 12.0 and later; 13.0 and later; 14.0 to before 14.20.1; 15.0 and later; 16.0 to before 16.17.1; 17.0 and later; 18.0 to before 18.9.1 Fixed in 14.20.1, 16.17.1, 18.9.1 Patch available CNA
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 14.0.0 – 14.14.0 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* | 14.15.0 to before 14.20.1 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 16.0.0 – 16.12.0 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* | 16.13.0 to before 16.17.1 | Vulnerable | NodeJS |
| cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* | 18.0.0 to before 18.5.0 | Vulnerable | NodeJS |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 14.0.0 – 14.14.0 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* Versions 14.15.0 to before 14.20.1 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 16.0.0 – 16.12.0 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:lts:*:*:* Versions 16.13.0 to before 16.17.1 Vulnerable ·NodeJS
- cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* Versions 18.0.0 to before 18.5.0 Vulnerable ·NodeJS
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Node (NodeJS) Fixed in 14.20.1, 16.17.1, 18.9.1
Red Hat 5 advisories
- RHSA-2022:6985 Released 2022-10-18 · Red Hat rating Moderatenodejs:14 security and bug fix update
- Red Hat Enterprise Linux AppStream EUS (v.8.4) nodejs-1:14.20.0-2.module+el8.4.0+16234+70f4adc8.aarch64::nodejs:14, nodejs-1:14.20.0-2.module+el8.4.0+16234+70f4adc8.ppc64le::nodejs:14, nodejs-1:14.20.0-2.module+el8.4.0+16234+70f4adc8.s390x::nodejs:14 +19
- RHSA-2022:6595 Released 2022-09-20 · Red Hat rating Moderatenodejs and nodejs-nodemon security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:16.16.0-1.el9_0, nodejs-docs-1:16.16.0-1.el9_0, nodejs-full-i18n-1:16.16.0-1.el9_0 +3
- RHSA-2022:6449 Released 2022-09-13 · Red Hat rating Moderatenodejs:16 security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:16.16.0-3.module+el8.6.0+16248+76b0e185.aarch64::nodejs:16, nodejs-1:16.16.0-3.module+el8.6.0+16248+76b0e185.ppc64le::nodejs:16, nodejs-1:16.16.0-3.module+el8.6.0+16248+76b0e185.s390x::nodejs:16 +19
Show 2 more Red Hat advisories
- RHSA-2022:6448 Released 2022-09-13 · Red Hat rating Moderatenodejs:14 security and bug fix update
- Red Hat Enterprise Linux AppStream (v. 8) nodejs-1:14.20.0-2.module+el8.6.0+16231+7c1b33d9.aarch64::nodejs:14, nodejs-1:14.20.0-2.module+el8.6.0+16231+7c1b33d9.ppc64le::nodejs:14, nodejs-1:14.20.0-2.module+el8.6.0+16231+7c1b33d9.s390x::nodejs:14 +19
- RHSA-2022:6389 Released 2022-09-08 · Red Hat rating Moderaterh-nodejs14-nodejs and rh-nodejs14-nodejs-nodemon security and bug fix update
- Red Hat Software Collections for RHEL Workstation(v. 7) rh-nodejs14-nodejs-14.20.0-2.el7, rh-nodejs14-nodejs-devel-14.20.0-2.el7, rh-nodejs14-nodejs-docs-14.20.0-2.el7 +2
- Red Hat Software Collections for RHEL(v. 7) rh-nodejs14-nodejs-14.20.0-2.el7, rh-nodejs14-nodejs-devel-14.20.0-2.el7, rh-nodejs14-nodejs-docs-14.20.0-2.el7 +2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2022:6448, RHSA-2022:6449 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2022:6595 |
| Red Hat Enterprise Linux AppStream EUS (v.8.4) | Fixed | RHSA-2022:6985 |
| Red Hat Software Collections for RHEL Workstation(v. 7) | Fixed | RHSA-2022:6389 |
| Red Hat Software Collections for RHEL(v. 7) | Fixed | RHSA-2022:6389 |
Not affected: 4 products
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux AppStream (v. 9)
- Red Hat Software Collections for RHEL Workstation(v. 7)
- Red Hat Software Collections for RHEL(v. 7)
Timeline
- 2026-10-02 Threatist record created from CVE-2022-32212
- 2026-10-03 Alias added: GHSA-w95h-2gj2-x2p4
References
More NodeJS Node.js vulnerabilities
- TI-2026-79288 Out-of-bounds write in Google Brotli decoder KEVCVSS 4.0CRITICAL 9.2
- TI-2023-23979 The HTTP/2 protocol allows a denial of service (server resource consumption) because… KEVCVSS 3.1HIGH 7.5
- TI-2016-01993 The DES and Triple DES ciphers, as used in the TLS, SSH, and IPSec protocols and other… CVSS 3.1HIGH 7.5
- TI-2024-03325 Command injection vulnerability in programing languages on Microsoft Windows operating system. CVSS 3.1CRITICAL 9.8
- TI-2022-03472 X.509 Email Address Variable Length Buffer Overflow CVSS 3.1HIGH 7.5
- TI-2022-03315 X.509 Email Address 4-byte Buffer Overflow CVSS 3.1HIGH 7.5
Sources
- CVE-2022-32212 · CVE Program
- CVE-2022-32212 · NVD
- FIRST EPSS
- GHSA-w95h-2gj2-x2p4 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-32212 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences