User Group Privilege Escalation
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A carefully crafted invocation on the Image plugin could trigger an CSRF vulnerability on Apache JSPWiki before 2.11.3, which could allow a group privilege escalation of the attacker's account. Further examination of this issue established that it could also be used to modify the email associated with the attacked account, and then a reset password request from the login page.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache JSPWiki | up to Apache JSPWiki up to 2.11.2 | — | No fix listed | CNA |
| — | org.apache.jspwiki:jspwiki-main (Maven) | before 2.11.3 | 2.11.3 | Patch available | GHSA-jp3m-p26h-mm7v |
- Apache JSPWiki VendorApache Affected up to Apache JSPWiki up to 2.11.2 Fixed in — No fix listed CNA
- org.apache.jspwiki:jspwiki-main (Maven) Vendor— Affected before 2.11.3 Fixed in 2.11.3 Patch available GHSA-jp3m-p26h-mm7v
Remediation
- Fix · GHSA-jp3m-p26h-mm7v org.apache.jspwiki:jspwiki-main (Maven) Fixed in 2.11.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34158
- 2026-10-03 Alias added: GHSA-jp3m-p26h-mm7v
References
More Apache Jspwiki vulnerabilities
- TI-2022-11364 Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp CVSS 3.1MEDIUM 6.1
- TI-2022-10292 XSS vulnerability on XHRHtml2Markup.jsp in JSPWiki 2.11.2 CVSS 3.1MEDIUM 6.1
- TI-2022-11366 Apache JSPWiki Cross-site scripting vulnerability on WeblogPlugin CVSS 3.1MEDIUM 6.1
- TI-2022-11365 Apache JSPWiki CSRF in UserPreferences.jsp CVSS 3.1MEDIUM 6.5
- TI-2024-17991 Apache JSPWiki: Cross-site scripting vulnerability on upload page CVSS 3.1MEDIUM 6.1
- TI-2026-23006 Apache JSPWiki: UserManager does not sanity-check user database at startup CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-34158 · CVE Program
- CVE-2022-34158 · NVD
- FIRST EPSS
- GHSA-jp3m-p26h-mm7v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences