Apache Geode stored Cross-Site Scripting (XSS) via data injection vulnerability in Pulse web application
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Apache Geode versions up to 1.15.0 are vulnerable to a Cross-Site Scripting (XSS) via data injection when using Pulse web application to view Region entries.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01375 72nd percentileScored 2026-11-07
Fix Fixed org.apache.geode:geode-core (Maven): 1.15.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Geode | Apache Geode – 1.15.0 | — | No fix listed | CNA |
| — | org.apache.geode:geode-core (Maven) | before 1.15.1 | 1.15.1 | Patch available | GHSA-373r-9mg8-3jc4 |
- Apache Geode VendorApache Affected Apache Geode – 1.15.0 Fixed in — No fix listed CNA
- org.apache.geode:geode-core (Maven) Vendor— Affected before 1.15.1 Fixed in 1.15.1 Patch available GHSA-373r-9mg8-3jc4
Remediation
- Fix · GHSA-373r-9mg8-3jc4 org.apache.geode:geode-core (Maven) Fixed in 1.15.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-34870
- 2026-10-03 Alias added: GHSA-373r-9mg8-3jc4
References
Advisory 3
More Apache Geode vulnerabilities
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
- TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
- TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
- TI-2017-11466 Deserialization of untrusted data in Apache Geode CVSS 3.0CRITICAL 9.8
- TI-2022-17225 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-34870 · CVE Program
- CVE-2022-34870 · NVD
- FIRST EPSS
- GHSA-373r-9mg8-3jc4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences