Read the docs
TI-2022-16121 Aliases CVE-2022-35655GHSA-wvf4-j5w7-r38j

Pega Platform from 7.3 to 8.7.3 is affected by an XSS issue due to a misconfiguration of a datapage setting.

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

Pega Platform from 7.3 to 8.7.3 is affected by an XSS issue due to a misconfiguration of a datapage setting.

Why it matters now

EPSS 0.00485 42nd percentileScored 2026-11-07
Fix Fixed Pega Infinity (Pegasystems): 8.7.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
PegasystemsPega Infinity7.3 and later; before 8.7.38.7.3Patch availableCNA
  • Pega Infinity VendorPegasystems Affected 7.3 and later; before 8.7.3 Fixed in 8.7.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:*7.3 – 8.7.3VulnerablePegasystems
  • cpe:2.3:a:pega:pega_platform:*:*:*:*:*:*:*:* Versions 7.3 – 8.7.3 Vulnerable ·Pegasystems

Remediation

  • Fix · CNA Pega Infinity (Pegasystems) Fixed in 8.7.3

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Pegasystems Pega Infinity 8.7.3, unspecified

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2022-16120 Pega Platform from 8.5.4 to 8.7.3 is affected by an XSS issue with an unauthenticated user and the redirect parameter.Priority LOW 28
    • TI-2022-16122 Cross-site request forgery in Pegasystems Pega InfinityPriority LOW 21

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-35655
  2. 2026-10-03 Alias added: GHSA-wvf4-j5w7-r38j

References

  • TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
  • TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
  • TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
  • TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
  • TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
  • TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
See all 28 →

Sources