Read the docs
TI-2022-16367 Aliases CVE-2022-35940GHSA-x989-q2pq-4q5x

Int overflow in `RaggedRangeOp` in Tensoflow

Priority LOW 34CWE-190Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.

Summary

TensorFlow is an open source platform for machine learning. The `RaggedRangOp` function takes an argument `limits` that is eventually used to construct a `TensorShape` as an `int64`. If `limits` is a very large float, it can overflow when converted to an `int64`. This triggers an `InvalidArgument` but also throws an abort signal that crashes the program. We have patched the issue in GitHub commit 37cefa91bee4eace55715eeef43720b958a01192. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00701 53rd percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.7.2, 2.8.1, 2.9.1tensorflow (PyPI): 2.7.2, 2.8.1, 2.9.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflowbefore 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.12.7.2, 2.8.1, 2.9.1Patch availableCNA
—tensorflow (PyPI)before 2.7.22.7.2Patch availableGHSA-x989-q2pq-4q5x
—tensorflow (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-x989-q2pq-4q5x
—tensorflow (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-x989-q2pq-4q5x
—tensorflow-cpu (PyPI)before 2.7.22.7.2Patch availableGHSA-x989-q2pq-4q5x
—tensorflow-cpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-x989-q2pq-4q5x
—tensorflow-cpu (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-x989-q2pq-4q5x
—tensorflow-gpu (PyPI)before 2.7.22.7.2Patch availableGHSA-x989-q2pq-4q5x
—tensorflow-gpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-x989-q2pq-4q5x
—tensorflow-gpu (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-x989-q2pq-4q5x
  • tensorflow VendorGoogle Affected before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Fixed in 2.7.2, 2.8.1, 2.9.1 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow-cpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-x989-q2pq-4q5x
  • tensorflow-gpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-x989-q2pq-4q5x

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*2.7.0 to before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:*2.10 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:*2.10 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:*2.10 rc2VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:*2.10 rc3VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:* Versions 2.10 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:* Versions 2.10 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:* Versions 2.10 rc2 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:* Versions 2.10 rc3 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.7.2, 2.8.1, 2.9.1
  • Fix · GHSA-x989-q2pq-4q5x tensorflow (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow (PyPI) Fixed in 2.9.1 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow-cpu (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow-cpu (PyPI) Fixed in 2.9.1 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow-gpu (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-x989-q2pq-4q5x tensorflow-gpu (PyPI) Fixed in 2.9.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-35940
  2. 2026-10-03 Alias added: GHSA-x989-q2pq-4q5x

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources