`CHECK` failures in `AvgPool3DGrad` in TensorFlow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-617.
Summary
TensorFlow is an open source platform for machine learning. The implementation of `AvgPool3DGradOp` does not fully validate the input `orig_input_shape`. This results in an overflow that results in a `CHECK` failure which can be used to trigger a denial of service attack. We have patched the issue in GitHub commit 9178ac9d6389bdc54638ab913ea0e419234d14eb. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 | 2.7.2, 2.8.1, 2.9.1 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.7.2 | 2.7.2 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow (PyPI) | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow-cpu (PyPI) | before 2.7.2 | 2.7.2 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow-cpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow-cpu (PyPI) | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow-gpu (PyPI) | before 2.7.2 | 2.7.2 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow-gpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-wxjj-cgcx-r3vq |
| — | tensorflow-gpu (PyPI) | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | GHSA-wxjj-cgcx-r3vq |
- tensorflow VendorGoogle Affected before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Fixed in 2.7.2, 2.8.1, 2.9.1 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow-cpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow-cpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow-gpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-wxjj-cgcx-r3vq
- tensorflow-gpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-wxjj-cgcx-r3vq
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | 2.7.0 to before 2.7.2 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.8.0:*:*:*:*:*:*:* | 2.8.0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.9.0:*:*:*:*:*:*:* | 2.9.0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:* | 2.10 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:* | 2.10 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:* | 2.10 rc2 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:* | 2.10 rc3 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.2 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.8.0:*:*:*:*:*:*:* Versions 2.8.0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.9.0:*:*:*:*:*:*:* Versions 2.9.0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:* Versions 2.10 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:* Versions 2.10 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:* Versions 2.10 rc2 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:* Versions 2.10 rc3 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.7.2, 2.8.1, 2.9.1
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow (PyPI) Fixed in 2.9.1 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow-cpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow-cpu (PyPI) Fixed in 2.9.1 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow-gpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-wxjj-cgcx-r3vq tensorflow-gpu (PyPI) Fixed in 2.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-35959
- 2026-10-03 Alias added: GHSA-wxjj-cgcx-r3vq
References
Patch 2
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2022-35959 · CVE Program
- CVE-2022-35959 · NVD
- FIRST EPSS
- GHSA-wxjj-cgcx-r3vq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences