`CHECK` fail in `FakeQuantWithMinMaxVarsGradient` in TensorFlow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-617.
Summary
TensorFlow is an open source platform for machine learning. When `tf.quantization.fake_quant_with_min_max_vars_gradient` receives input `min` or `max` that is nonscalar, it gives a `CHECK` fail that can trigger a denial of service attack. We have patched the issue in GitHub commit f3cf67ac5705f4f04721d15e485e192bb319feed. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 | 2.7.2, 2.8.1, 2.9.1 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.7.2 | 2.7.2 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow (PyPI) | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow-cpu (PyPI) | before 2.7.2 | 2.7.2 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow-cpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow-cpu (PyPI) | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow-gpu (PyPI) | before 2.7.2 | 2.7.2 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow-gpu (PyPI) | 2.8.0 to before 2.8.1 | 2.8.1 | Patch available | GHSA-r26c-679w-mrjm |
| — | tensorflow-gpu (PyPI) | 2.9.0 to before 2.9.1 | 2.9.1 | Patch available | GHSA-r26c-679w-mrjm |
- tensorflow VendorGoogle Affected before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Fixed in 2.7.2, 2.8.1, 2.9.1 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-r26c-679w-mrjm
- tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-r26c-679w-mrjm
- tensorflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-r26c-679w-mrjm
- tensorflow-cpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-r26c-679w-mrjm
- tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-r26c-679w-mrjm
- tensorflow-cpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-r26c-679w-mrjm
- tensorflow-gpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-r26c-679w-mrjm
- tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-r26c-679w-mrjm
- tensorflow-gpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-r26c-679w-mrjm
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* | before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:* | 2.10 rc0 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:* | 2.10 rc1 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:* | 2.10 rc2 | Vulnerable | |
| cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:* | 2.10 rc3 | Vulnerable |
- cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:* Versions 2.10 rc0 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:* Versions 2.10 rc1 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:* Versions 2.10 rc2 Vulnerable ·Google
- cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:* Versions 2.10 rc3 Vulnerable ·Google
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.7.2, 2.8.1, 2.9.1
- Fix · GHSA-r26c-679w-mrjm tensorflow (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow (PyPI) Fixed in 2.9.1 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow-cpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow-cpu (PyPI) Fixed in 2.9.1 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow-gpu (PyPI) Fixed in 2.7.2 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →
- Fix · GHSA-r26c-679w-mrjm tensorflow-gpu (PyPI) Fixed in 2.9.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-36005
- 2026-10-03 Alias added: GHSA-r26c-679w-mrjm
References
Advisory 2
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2022-36005 · CVE Program
- CVE-2022-36005 · NVD
- FIRST EPSS
- GHSA-r26c-679w-mrjm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences