Read the docs
TI-2022-16451 Aliases CVE-2022-36026GHSA-9cr2-8pwr-fhfq

`CHECK` fail in `QuantizeAndDequantizeV3` in TensorFlow

Priority LOW 33CWE-617Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-617.

Summary

TensorFlow is an open source platform for machine learning. If `QuantizeAndDequantizeV3` is given a nonscalar `num_bits` input tensor, it results in a `CHECK` fail that can be used to trigger a denial of service attack. We have patched the issue in GitHub commit f3f9cb38ecfe5a8a703f2c4a8fead434ef291713. The fix will be included in TensorFlow 2.10.0. We will also cherrypick this commit on TensorFlow 2.9.1, TensorFlow 2.8.1, and TensorFlow 2.7.2, as these are also affected and still in supported range. There are no known workarounds for this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00478 41st percentileScored 2026-11-07
Fix Fixed tensorflow (tensorflow): 2.7.2, 2.8.1, 2.9.1tensorflow (PyPI): 2.7.2, 2.8.1, 2.9.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflowbefore 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.12.7.2, 2.8.1, 2.9.1Patch availableCNA
—tensorflow (PyPI)before 2.7.22.7.2Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow-cpu (PyPI)before 2.7.22.7.2Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow-cpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow-cpu (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow-gpu (PyPI)before 2.7.22.7.2Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow-gpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-9cr2-8pwr-fhfq
—tensorflow-gpu (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-9cr2-8pwr-fhfq
  • tensorflow VendorGoogle Affected before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Fixed in 2.7.2, 2.8.1, 2.9.1 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow-cpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.7.2 Fixed in 2.7.2 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-9cr2-8pwr-fhfq
  • tensorflow-gpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-9cr2-8pwr-fhfq

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:*2.10 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:*2.10 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:*2.10 rc2VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:*2.10 rc3VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.7.2; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc0:*:*:*:*:*:* Versions 2.10 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc1:*:*:*:*:*:* Versions 2.10 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc2:*:*:*:*:*:* Versions 2.10 rc2 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10:rc3:*:*:*:*:*:* Versions 2.10 rc3 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.7.2, 2.8.1, 2.9.1
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow (PyPI) Fixed in 2.9.1 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow-cpu (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow-cpu (PyPI) Fixed in 2.9.1 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow-gpu (PyPI) Fixed in 2.7.2 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-9cr2-8pwr-fhfq tensorflow-gpu (PyPI) Fixed in 2.9.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-36026
  2. 2026-10-03 Alias added: GHSA-9cr2-8pwr-fhfq

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources