Read the docs
TI-2022-17227 Aliases CVE-2022-37023GHSA-72x9-48mc-phh6

Apache Geode deserialization of untrusted data flaw when using REST API on Java 8 or Java 11

Priority LOW 32CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.

Why it matters now

EPSS 0.01783 78th percentileScored 2026-11-07
Fix Fixed Apache Geode (Apache Software Foundation): 1.15.0org.apache.geode:geode-core (Maven): 1.15.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache GeodeApache Geode to before 1.15.01.15.0Patch availableCNA
—org.apache.geode:geode-core (Maven)before 1.15.01.15.0Patch availableGHSA-72x9-48mc-phh6
  • Apache Geode VendorApache Affected Apache Geode to before 1.15.0 Fixed in 1.15.0 Patch available CNA
  • org.apache.geode:geode-core (Maven) Vendor— Affected before 1.15.0 Fixed in 1.15.0 Patch available GHSA-72x9-48mc-phh6

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:geode:*:*:*:*:*:*:*:*before 1.15.0VulnerableApache
  • cpe:2.3:a:apache:geode:*:*:*:*:*:*:*:* Versions before 1.15.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Geode (Apache Software Foundation) Fixed in 1.15.0
  • Fix · GHSA-72x9-48mc-phh6 org.apache.geode:geode-core (Maven) Fixed in 1.15.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-37023
  2. 2026-10-03 Alias added: GHSA-72x9-48mc-phh6

References

  • TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-11833 Docker Desktop Community Edition before 2.1.0.1 allows local users to gain privileges by… KEVCVSS 3.1HIGH 7.8
  • TI-2019-11096 Information disclosure in Red Hat jackson-databind CVSS 3.1CRITICAL 9.8
  • TI-2014-00046 Improper input validation in docker.io CVSS 3.1CRITICAL 9.8
  • TI-2017-11466 Deserialization of untrusted data in Apache Geode CVSS 3.0CRITICAL 9.8
  • TI-2022-17225 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. CVSS 3.1CRITICAL 9.8
See all 22 →

Sources