Read the docs
TI-2022-17364 Aliases CVE-2022-37247GHSA-3cvm-7wrh-qrf9

Craft CMS 4.2.0.1 is vulnerable to stored a cross-site scripting (XSS) via /admin/settings/fields page.

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Craft CMS 4.2.0.1 is vulnerable to stored a cross-site scripting (XSS) via /admin/settings/fields page.

Why it matters now

EPSS 0.00566 47th percentileScored 2026-11-07
Fix Fixed craftcms/cms (Packagist): 4.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—craftcms/cms (Packagist)4.0.0-RC1 to before 4.2.14.2.1Patch availableGHSA-3cvm-7wrh-qrf9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.2.1 Fixed in 4.2.1 Patch available GHSA-3cvm-7wrh-qrf9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:craftcms:craft_cms:4.2.0.1:*:*:*:*:*:*:*4.2.0.1VulnerableCraft CMS
  • cpe:2.3:a:craftcms:craft_cms:4.2.0.1:*:*:*:*:*:*:* Versions 4.2.0.1 Vulnerable ·Craft CMS

Remediation

  • Fix · GHSA-3cvm-7wrh-qrf9 craftcms/cms (Packagist) Fixed in 4.2.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-37247
  2. 2026-10-03 Alias added: GHSA-3cvm-7wrh-qrf9

References

  • TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
  • TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
  • TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
  • TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
See all 96 →

Sources