Apache Dubbo Hession Deserialization Vulnerability Gadgets Bypass
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
A deserialization vulnerability existed in dubbo hessian-lite 3.2.12 and its earlier versions, which could lead to malicious code execution. This issue affects Apache Dubbo 2.7.x version 2.7.17 and prior versions; Apache Dubbo 3.0.x version 3.0.11 and prior versions; Apache Dubbo 3.1.x version 3.1.0 and prior versions.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Dubbo | Apache Dubbo 2.7.x – 2.7.17; Apache Dubbo 3.0.x – 3.0.11; Apache Dubbo 3.1.x – 3.1.0 | — | No fix listed | CNA |
| — | com.alibaba:hessian-lite (Maven) | before 3.2.13 | 3.2.13 | Patch available | GHSA-5qwq-g2hx-r6f7 |
| — | org.apache.dubbo:dubbo (Maven) | 2.7.0 to before 2.7.18 | 2.7.18 | Patch available | GHSA-5qwq-g2hx-r6f7 |
| — | org.apache.dubbo:dubbo (Maven) | 3.0.0 to before 3.0.12 | 3.0.12 | Patch available | GHSA-5qwq-g2hx-r6f7 |
| — | org.apache.dubbo:dubbo (Maven) | 3.1.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-5qwq-g2hx-r6f7 |
- Apache Dubbo VendorApache Affected Apache Dubbo 2.7.x – 2.7.17; Apache Dubbo 3.0.x – 3.0.11; Apache Dubbo 3.1.x – 3.1.0 Fixed in — No fix listed CNA
- com.alibaba:hessian-lite (Maven) Vendor— Affected before 3.2.13 Fixed in 3.2.13 Patch available GHSA-5qwq-g2hx-r6f7
- org.apache.dubbo:dubbo (Maven) Vendor— Affected 2.7.0 to before 2.7.18 Fixed in 2.7.18 Patch available GHSA-5qwq-g2hx-r6f7
- org.apache.dubbo:dubbo (Maven) Vendor— Affected 3.0.0 to before 3.0.12 Fixed in 3.0.12 Patch available GHSA-5qwq-g2hx-r6f7
- org.apache.dubbo:dubbo (Maven) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-5qwq-g2hx-r6f7
Remediation
- Fix · GHSA-5qwq-g2hx-r6f7 com.alibaba:hessian-lite (Maven) Fixed in 3.2.13 Advisory →
- Fix · GHSA-5qwq-g2hx-r6f7 org.apache.dubbo:dubbo (Maven) Fixed in 2.7.18 Advisory →
- Fix · GHSA-5qwq-g2hx-r6f7 org.apache.dubbo:dubbo (Maven) Fixed in 3.0.12 Advisory →
- Fix · GHSA-5qwq-g2hx-r6f7 org.apache.dubbo:dubbo (Maven) Fixed in 3.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-39198
- 2026-10-03 Alias added: GHSA-5qwq-g2hx-r6f7
References
Advisory 2
More Apache Dubbo vulnerabilities
- TI-2021-12489 Regular expression Denial of Service in MooTools CVSS 3.1CRITICAL 9.8
- TI-2021-10721 Apache Dubbo RCE on customers via Script route poisoning (Nashorn script injection) CVSS 3.1CRITICAL 9.8
- TI-2021-10720 Apache Dubbo RCE on customers via Condition route poisoning (Unsafe YAML unmarshaling) CVSS 3.1CRITICAL 9.8
- TI-2019-13107 Deserialization of untrusted data in Apache Dubbo CVSS 3.1CRITICAL 9.8
- TI-2021-07774 Dubbo Zookeeper does not check serialization id CVSS 3.1CRITICAL 9.8
- TI-2021-19290 Dubbo Hessian cause RCE when parse error CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-39198 · CVE Program
- CVE-2022-39198 · NVD
- FIRST EPSS
- GHSA-5qwq-g2hx-r6f7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences