Read the docs
TI-2022-19074 Aliases CVE-2022-40208GHSA-948f-j464-rfj2

Improper authorization in Moodle

Priority LOW 21CWE-285Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-285.

Summary

In Moodle, insufficient limitations in some quiz web services made it possible for students to bypass sequential navigation during a quiz attempt.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00563 47th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 4.0.3, 3.11.9, 3.9.16

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Moodleaffected 4.0 to 4.0.2, 3.11 to 3.11.8, 3.9 to 3.9.15 and earlier unsupported versions—No fix listedCNA
—moodle/moodle (Packagist)4.0.0 to before 4.0.34.0.3Patch availableGHSA-948f-j464-rfj2
—moodle/moodle (Packagist)3.11.0 to before 3.11.93.11.9Patch availableGHSA-948f-j464-rfj2
—moodle/moodle (Packagist)before 3.9.163.9.16Patch availableGHSA-948f-j464-rfj2
  • Moodle Vendor— Affected affected 4.0 to 4.0.2, 3.11 to 3.11.8, 3.9 to 3.9.15 and earlier unsupported versions Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.0.0 to before 4.0.3 Fixed in 4.0.3 Patch available GHSA-948f-j464-rfj2
  • moodle/moodle (Packagist) Vendor— Affected 3.11.0 to before 3.11.9 Fixed in 3.11.9 Patch available GHSA-948f-j464-rfj2
  • moodle/moodle (Packagist) Vendor— Affected before 3.9.16 Fixed in 3.9.16 Patch available GHSA-948f-j464-rfj2

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*after 3.9.0, before 3.9.16; after 3.11.0, before 3.11.9; after 4.0.0, before 4.0.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:*3.9.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:*3.11.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:*4.0.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions after 3.9.0, before 3.9.16; after 3.11.0, before 3.11.9; after 4.0.0, before 4.0.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.9.0:-:*:*:*:*:*:* Versions 3.9.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.11.0:-:*:*:*:*:*:* Versions 3.11.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-948f-j464-rfj2 moodle/moodle (Packagist) Fixed in 4.0.3 Advisory →
  • Fix · GHSA-948f-j464-rfj2 moodle/moodle (Packagist) Fixed in 3.11.9 Advisory →
  • Fix · GHSA-948f-j464-rfj2 moodle/moodle (Packagist) Fixed in 3.9.16 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-40208
  2. 2026-10-03 Alias added: GHSA-948f-j464-rfj2

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources