A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
Priority MEDIUM 53CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
A remote code execution risk when restoring backup files originating from Moodle 1.9 was identified.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02101 81st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.9.17, 3.11.10, 4.0.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 3.9.17 | 3.9.17 | Patch available | GHSA-2hmm-q272-xmhf |
| — | moodle/moodle (Packagist) | 3.11 to before 3.11.10 | 3.11.10 | Patch available | GHSA-2hmm-q272-xmhf |
| — | moodle/moodle (Packagist) | 4.0 to before 4.0.4 | 4.0.4 | Patch available | GHSA-2hmm-q272-xmhf |
- moodle Vendor— Affected 4.0 to 4.0.3, 3.11 to 3.11.9, 3.9 to 3.9.16 and earlier unsupported versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 3.9.17 Fixed in 3.9.17 Patch available GHSA-2hmm-q272-xmhf
- moodle/moodle (Packagist) Vendor— Affected 3.11 to before 3.11.10 Fixed in 3.11.10 Patch available GHSA-2hmm-q272-xmhf
- moodle/moodle (Packagist) Vendor— Affected 4.0 to before 4.0.4 Fixed in 4.0.4 Patch available GHSA-2hmm-q272-xmhf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9 to before 3.9.17; 3.11 to before 3.11.10; 4.0 to before 4.0.4 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9 to before 3.9.17; 3.11 to before 3.11.10; 4.0 to before 4.0.4 Vulnerable ·Moodle
Remediation
- Fix · GHSA-2hmm-q272-xmhf moodle/moodle (Packagist) Fixed in 3.9.17 Advisory →
- Fix · GHSA-2hmm-q272-xmhf moodle/moodle (Packagist) Fixed in 3.11.10 Advisory →
- Fix · GHSA-2hmm-q272-xmhf moodle/moodle (Packagist) Fixed in 4.0.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-40314
- 2026-10-03 Alias added: GHSA-2hmm-q272-xmhf
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2022-40314 · CVE Program
- CVE-2022-40314 · NVD
- FIRST EPSS
- GHSA-2hmm-q272-xmhf · GitHub Advisory Database · CC BY 4.0
- CVE-2022-40314 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences