Read the docs
TI-2022-20226 Aliases CVE-2022-41885GHSA-762h-vpvw-3rcx

Overflow in `FusedResizeAndPadConv2D` in Tensorflow

Priority HIGH 66CWE-131Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-131 and the CVSS impact.

Summary

TensorFlow is an open source platform for machine learning. When `tf.raw_ops.FusedResizeAndPadConv2D` is given a large tensor shape, it overflows. We have patched the issue in GitHub commit d66e1d568275e6a2947de97dca7a102a211e01ce. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00472 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.9.1, 2.8.1, 2.7.4tensorflow (PyPI): 2.7.4, 2.8.1, 2.9.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.9.0 to before 2.9.1; 2.8.0 to before 2.8.1; before 2.7.42.9.1, 2.8.1, 2.7.4Patch availableCNA
—tensorflow (PyPI)before 2.7.42.7.4Patch availableGHSA-762h-vpvw-3rcx
—tensorflow (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-762h-vpvw-3rcx
—tensorflow (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-762h-vpvw-3rcx
—tensorflow-cpu (PyPI)before 2.7.42.7.4Patch availableGHSA-762h-vpvw-3rcx
—tensorflow-gpu (PyPI)before 2.7.42.7.4Patch availableGHSA-762h-vpvw-3rcx
—tensorflow-cpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-762h-vpvw-3rcx
—tensorflow-gpu (PyPI)2.8.0 to before 2.8.12.8.1Patch availableGHSA-762h-vpvw-3rcx
—tensorflow-cpu (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-762h-vpvw-3rcx
—tensorflow-gpu (PyPI)2.9.0 to before 2.9.12.9.1Patch availableGHSA-762h-vpvw-3rcx
  • tensorflow VendorGoogle Affected 2.9.0 to before 2.9.1; 2.8.0 to before 2.8.1; before 2.7.4 Fixed in 2.9.1, 2.8.1, 2.7.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.7.4 Fixed in 2.7.4 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.7.4 Fixed in 2.7.4 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.7.4 Fixed in 2.7.4 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow-cpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow-gpu (PyPI) Vendor— Affected 2.8.0 to before 2.8.1 Fixed in 2.8.1 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow-cpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-762h-vpvw-3rcx
  • tensorflow-gpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.1 Fixed in 2.9.1 Patch available GHSA-762h-vpvw-3rcx

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*before 2.7.4; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10.0:rc0:*:*:*:*:*:*2.10.0 rc0VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10.0:rc1:*:*:*:*:*:*2.10.0 rc1VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10.0:rc2:*:*:*:*:*:*2.10.0 rc2VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10.0:rc3:*:*:*:*:*:*2.10.0 rc3VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.7.4; 2.8.0 to before 2.8.1; 2.9.0 to before 2.9.1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10.0:rc0:*:*:*:*:*:* Versions 2.10.0 rc0 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10.0:rc1:*:*:*:*:*:* Versions 2.10.0 rc1 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10.0:rc2:*:*:*:*:*:* Versions 2.10.0 rc2 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10.0:rc3:*:*:*:*:*:* Versions 2.10.0 rc3 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.9.1, 2.8.1, 2.7.4
  • Fix · GHSA-762h-vpvw-3rcx tensorflow (PyPI) Fixed in 2.7.4 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow (PyPI) Fixed in 2.9.1 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow-cpu (PyPI) Fixed in 2.7.4 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow-gpu (PyPI) Fixed in 2.7.4 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow-cpu (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow-gpu (PyPI) Fixed in 2.8.1 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow-cpu (PyPI) Fixed in 2.9.1 Advisory →
  • Fix · GHSA-762h-vpvw-3rcx tensorflow-gpu (PyPI) Fixed in 2.9.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-41885
  2. 2026-10-03 Alias added: GHSA-762h-vpvw-3rcx

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources