Overflow in `tf.keras.losses.poisson` in Tensorflow
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-131 and the CVSS impact.
Summary
TensorFlow is an open source platform for machine learning. `tf.keras.losses.poisson` receives a `y_pred` and `y_true` that are passed through `functor::mul` in `BinaryOp`. If the resulting dimensions overflow an `int32`, TensorFlow will crash due to a size mismatch during broadcast assignment. We have patched the issue in GitHub commit c5b30379ba87cbe774b08ac50c1f6d36df4ebb7c. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1 and 2.9.3, as these are also affected and still in supported range. However, we will not cherrypick this commit into TensorFlow 2.8.x, as it depends on Eigen behavior that changed between 2.8 and 2.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| tensorflow | 2.10.0 to before 2.10.1; before 2.9.3 | 2.10.1, 2.9.3 | Patch available | CNA | |
| — | tensorflow (PyPI) | before 2.9.3 | 2.9.3 | Patch available | GHSA-8fvv-46hw-vpg3 |
| — | tensorflow (PyPI) | 2.10.0 to before 2.10.1 | 2.10.1 | Patch available | GHSA-8fvv-46hw-vpg3 |
| — | tensorflow-cpu (PyPI) | before 2.9.3 | 2.9.3 | Patch available | GHSA-8fvv-46hw-vpg3 |
| — | tensorflow-gpu (PyPI) | before 2.9.3 | 2.9.3 | Patch available | GHSA-8fvv-46hw-vpg3 |
| — | tensorflow-cpu (PyPI) | 2.10.0 to before 2.10.1 | 2.10.1 | Patch available | GHSA-8fvv-46hw-vpg3 |
| — | tensorflow-gpu (PyPI) | 2.10.0 to before 2.10.1 | 2.10.1 | Patch available | GHSA-8fvv-46hw-vpg3 |
- tensorflow VendorGoogle Affected 2.10.0 to before 2.10.1; before 2.9.3 Fixed in 2.10.1, 2.9.3 Patch available CNA
- tensorflow (PyPI) Vendor— Affected before 2.9.3 Fixed in 2.9.3 Patch available GHSA-8fvv-46hw-vpg3
- tensorflow (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-8fvv-46hw-vpg3
- tensorflow-cpu (PyPI) Vendor— Affected before 2.9.3 Fixed in 2.9.3 Patch available GHSA-8fvv-46hw-vpg3
- tensorflow-gpu (PyPI) Vendor— Affected before 2.9.3 Fixed in 2.9.3 Patch available GHSA-8fvv-46hw-vpg3
- tensorflow-cpu (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-8fvv-46hw-vpg3
- tensorflow-gpu (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-8fvv-46hw-vpg3
Remediation
- Fix · CNA tensorflow (tensorflow) Fixed in 2.10.1, 2.9.3
- Fix · GHSA-8fvv-46hw-vpg3 tensorflow (PyPI) Fixed in 2.9.3 Advisory →
- Fix · GHSA-8fvv-46hw-vpg3 tensorflow (PyPI) Fixed in 2.10.1 Advisory →
- Fix · GHSA-8fvv-46hw-vpg3 tensorflow-cpu (PyPI) Fixed in 2.9.3 Advisory →
- Fix · GHSA-8fvv-46hw-vpg3 tensorflow-gpu (PyPI) Fixed in 2.9.3 Advisory →
- Fix · GHSA-8fvv-46hw-vpg3 tensorflow-cpu (PyPI) Fixed in 2.10.1 Advisory →
- Fix · GHSA-8fvv-46hw-vpg3 tensorflow-gpu (PyPI) Fixed in 2.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-41887
- 2026-10-03 Alias added: GHSA-8fvv-46hw-vpg3
References
Advisory 3
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2022-41887 · CVE Program
- CVE-2022-41887 · NVD
- FIRST EPSS
- GHSA-8fvv-46hw-vpg3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences