Read the docs
TI-2022-20250 Aliases CVE-2022-41909GHSA-rjx6-v474-2ch9

Segfault in `CompositeTensorVariantToComponents` in Tensorflow

Priority HIGH 66CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-476.

Summary

TensorFlow is an open source platform for machine learning. An input `encoded` that is not a valid `CompositeTensorVariant` tensor will trigger a segfault in `tf.raw_ops.CompositeTensorVariantToComponents`. We have patched the issue in GitHub commits bf594d08d377dc6a3354d9fdb494b32d45f91971 and 660ce5a89eb6766834bdc303d2ab3902aef99d3d. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00549 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed tensorflow (tensorflow): 2.10.1, 2.9.3, 2.8.4tensorflow (PyPI): 2.8.4, 2.9.3, 2.10.1+2 more products

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Googletensorflow2.10.0 to before 2.10.1; 2.9.0 to before 2.9.3; before 2.8.42.10.1, 2.9.3, 2.8.4Patch availableCNA
—tensorflow (PyPI)before 2.8.42.8.4Patch availableGHSA-rjx6-v474-2ch9
—tensorflow (PyPI)2.9.0 to before 2.9.32.9.3Patch availableGHSA-rjx6-v474-2ch9
—tensorflow (PyPI)2.10.0 to before 2.10.12.10.1Patch availableGHSA-rjx6-v474-2ch9
—tensorflow-cpu (PyPI)before 2.8.42.8.4Patch availableGHSA-rjx6-v474-2ch9
—tensorflow-gpu (PyPI)before 2.8.42.8.4Patch availableGHSA-rjx6-v474-2ch9
—tensorflow-cpu (PyPI)2.9.0 to before 2.9.32.9.3Patch availableGHSA-rjx6-v474-2ch9
—tensorflow-gpu (PyPI)2.9.0 to before 2.9.32.9.3Patch availableGHSA-rjx6-v474-2ch9
—tensorflow-cpu (PyPI)2.10.0 to before 2.10.12.10.1Patch availableGHSA-rjx6-v474-2ch9
—tensorflow-gpu (PyPI)2.10.0 to before 2.10.12.10.1Patch availableGHSA-rjx6-v474-2ch9
  • tensorflow VendorGoogle Affected 2.10.0 to before 2.10.1; 2.9.0 to before 2.9.3; before 2.8.4 Fixed in 2.10.1, 2.9.3, 2.8.4 Patch available CNA
  • tensorflow (PyPI) Vendor— Affected before 2.8.4 Fixed in 2.8.4 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow-cpu (PyPI) Vendor— Affected before 2.8.4 Fixed in 2.8.4 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow-gpu (PyPI) Vendor— Affected before 2.8.4 Fixed in 2.8.4 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow-cpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow-gpu (PyPI) Vendor— Affected 2.9.0 to before 2.9.3 Fixed in 2.9.3 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow-cpu (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-rjx6-v474-2ch9
  • tensorflow-gpu (PyPI) Vendor— Affected 2.10.0 to before 2.10.1 Fixed in 2.10.1 Patch available GHSA-rjx6-v474-2ch9

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:*before 2.8.4; 2.9.0 to before 2.9.3VulnerableGoogle
cpe:2.3:a:google:tensorflow:2.10.0:*:*:*:*:*:*:*2.10.0VulnerableGoogle
  • cpe:2.3:a:google:tensorflow:*:*:*:*:*:*:*:* Versions before 2.8.4; 2.9.0 to before 2.9.3 Vulnerable ·Google
  • cpe:2.3:a:google:tensorflow:2.10.0:*:*:*:*:*:*:* Versions 2.10.0 Vulnerable ·Google

Remediation

  • Fix · CNA tensorflow (tensorflow) Fixed in 2.10.1, 2.9.3, 2.8.4
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow (PyPI) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow (PyPI) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow (PyPI) Fixed in 2.10.1 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow-cpu (PyPI) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow-gpu (PyPI) Fixed in 2.8.4 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow-cpu (PyPI) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow-gpu (PyPI) Fixed in 2.9.3 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow-cpu (PyPI) Fixed in 2.10.1 Advisory →
  • Fix · GHSA-rjx6-v474-2ch9 tensorflow-gpu (PyPI) Fixed in 2.10.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-41909
  2. 2026-10-03 Alias added: GHSA-rjx6-v474-2ch9

References

  • TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
  • TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
  • TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
  • TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
See all 430 →

Sources