Read the docs
TI-2022-22657 Aliases CVE-2022-45855GHSA-p7w2-784m-qpq9

Apache Ambari: Allows authenticated metrics consumers to perform RCE

Priority MEDIUM 42CWE-917Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-917.

Summary

SpringEL injection in the metrics source in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01212 68th percentileScored 2026-11-07
Fix Fixed org.apache.ambari:ambari (Maven): 2.7.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Ambari2.7.0 – 2.7.6—No fix listedCNA
—org.apache.ambari:ambari (Maven)2.7.0 to before 2.7.72.7.7Patch availableGHSA-p7w2-784m-qpq9
  • Apache Ambari VendorApache Affected 2.7.0 – 2.7.6 Fixed in — No fix listed CNA
  • org.apache.ambari:ambari (Maven) Vendor— Affected 2.7.0 to before 2.7.7 Fixed in 2.7.7 Patch available GHSA-p7w2-784m-qpq9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:*2.7.0 to before 2.7.7VulnerableApache
  • cpe:2.3:a:apache:ambari:*:*:*:*:*:*:*:* Versions 2.7.0 to before 2.7.7 Vulnerable ·Apache

Remediation

  • Fix · GHSA-p7w2-784m-qpq9 org.apache.ambari:ambari (Maven) Fixed in 2.7.7 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-45855
  2. 2026-10-03 Alias added: GHSA-p7w2-784m-qpq9

References

  • TI-2016-05848 Improper access control in Apache Ambari CVSS 3.0CRITICAL 9.8
  • TI-2017-03642 During installation of Ambari 2.4.0 through 2.4.2, Ambari Server artifacts are not created with proper ACLs. CVSS 3.0CRITICAL 9.8
  • TI-2014-02906 In Ambari 1.2.0 through 2.2.2, it may be possible to execute arbitrary system commands on… CVSS 3.0CRITICAL 9.8
  • TI-2025-16981 Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition CVSS 3.1HIGH 8.8
  • TI-2024-34845 Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts CVSS 3.1HIGH 8.8
  • TI-2023-27565 Apache Ambari: authenticated users could perform command injection to perform RCE CVSS 3.1HIGH 8.8
See all 25 →

Sources