Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive_cli_params
Priority MEDIUM 55CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 5.0.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.03286 88th percentileScored 2026-11-07
Fix Fixed Apache Airflow Hive Provider (Apache Software Foundation): 5.0.0apache-airflow-providers-apache-hive (PyPI): 5.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Hive Provider | before 5.0.0 | 5.0.0 | Patch available | CNA |
| — | apache-airflow-providers-apache-hive (PyPI) | before 5.0.0 | 5.0.0 | Patch available | GHSA-rc58-qr9j-cpgw |
- Apache Airflow Hive Provider VendorApache Affected before 5.0.0 Fixed in 5.0.0 Patch available CNA
- apache-airflow-providers-apache-hive (PyPI) Vendor— Affected before 5.0.0 Fixed in 5.0.0 Patch available GHSA-rc58-qr9j-cpgw
Remediation
- Fix · CNA Apache Airflow Hive Provider (Apache Software Foundation) Fixed in 5.0.0
- Fix · GHSA-rc58-qr9j-cpgw apache-airflow-providers-apache-hive (PyPI) Fixed in 5.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-46421
- 2026-10-03 Alias added: GHSA-rc58-qr9j-cpgw
References
Patch 2
More Apache-airflow-providers-apache-hive vulnerabilities
- TI-2023-17885 Apache Airflow Hive Provider Beeline RCE with Principal CVSS 3.1CRITICAL 9.8
- TI-2023-10972 Apache Airflow Hive Provider Beeline RCE CVSS 3.1CRITICAL 9.8
- TI-2023-19029 Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy_user CVSS 3.1HIGH 8.8
- TI-2022-19650 Apache Airflow Hive Provider vulnerability (command injection via hive_cli connection) CVSS 3.1HIGH 7.8
Sources
- CVE-2022-46421 · CVE Program
- CVE-2022-46421 · NVD
- FIRST EPSS
- GHSA-rc58-qr9j-cpgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences