Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy_user
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.
Summary
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Apache Hive Provider. Patching on top of CVE-2023-35797 Before 6.1.2 the proxy_user option can also inject semicolon. This issue affects Apache Airflow Apache Hive Provider: before 6.1.2. It is recommended updating provider version to 6.1.2 in order to avoid this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Airflow Apache Hive Provider | before 6.1.2 | 6.1.2 | Patch available | CNA |
| — | apache-airflow-providers-apache-hive (PyPI) | before 6.1.2 | 6.1.2 | Patch available | GHSA-4q2q-q5pw-2342 |
- Apache Airflow Apache Hive Provider VendorApache Affected before 6.1.2 Fixed in 6.1.2 Patch available CNA
- apache-airflow-providers-apache-hive (PyPI) Vendor— Affected before 6.1.2 Fixed in 6.1.2 Patch available GHSA-4q2q-q5pw-2342
Remediation
- Fix · CNA Apache Airflow Apache Hive Provider (Apache Software Foundation) Fixed in 6.1.2
- Fix · GHSA-4q2q-q5pw-2342 apache-airflow-providers-apache-hive (PyPI) Fixed in 6.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-37415
- 2026-10-03 Alias added: GHSA-4q2q-q5pw-2342
References
More Apache-airflow-providers-apache-hive vulnerabilities
- TI-2022-22946 Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive_cli_params CVSS 3.1CRITICAL 9.8
- TI-2023-17885 Apache Airflow Hive Provider Beeline RCE with Principal CVSS 3.1CRITICAL 9.8
- TI-2023-10972 Apache Airflow Hive Provider Beeline RCE CVSS 3.1CRITICAL 9.8
- TI-2022-19650 Apache Airflow Hive Provider vulnerability (command injection via hive_cli connection) CVSS 3.1HIGH 7.8
Sources
- CVE-2023-37415 · CVE Program
- CVE-2023-37415 · NVD
- FIRST EPSS
- GHSA-4q2q-q5pw-2342 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences