PocketMine-MP before 3.26.5 and 4.0.5 Input Validation via Book Pages
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-400.
Summary
PocketMine-MP before 3.26.5 and 4.0.x before 4.0.5 does not limit book page text length, page count, or author/title length. A player who obtains a writable book can create oversized NBT ('book bombs'), causing excess bandwidth consumption and server crashes (exceeding the 1 MB chunk size limit when saving region-based worlds in PM3, or exceeding the 32 KiB TAG_String limit in PM4).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA PocketMine-MP (pmmp) Fixed in 3.26.5, 4.0.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
pmmp PocketMine-MP 3.26.5, 4.0.5
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2022-26446 PocketMine-MP before 3.26.5 and 4.0.5 Denial of Service via Skin DataPriority MEDIUM 45
Timeline
- 2026-10-02 Threatist record created from CVE-2022-51018
- 2026-10-03 Alias added: GHSA-q643-57w3-775x
References
More pmmp vulnerabilities
- TI-2026-58990 PocketMine-MP before 5.41.1 LogDoS via LoginPacket clientData CVSS 4.0HIGH 8.7
- TI-2026-58988 PocketMine-MP before 5.43.1 Denial of Service via unauthenticated login CVSS 4.0HIGH 8.7
- TI-2026-58993 PocketMine-MP before 5.39.2 Denial of Service via ModalFormResponsePacket CVSS 4.0HIGH 7.1
- TI-2024-38460 PocketMine-MP before 5.11.1 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2023-30643 PocketMine-MP before 4.20.5 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
- TI-2023-30640 PocketMine-MP before 5.3.1 Denial of Service via LoginPacket CVSS 4.0HIGH 8.7
Sources
- CVE-2022-51018 · CVE Program
- CVE-2022-51018 · NVD
- FIRST EPSS
- GHSA-q643-57w3-775x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences