VK All in One Expansion Unit < 9.86.0.0 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The VK All in One Expansion Unit WordPress plugin before 9.86.0.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0056 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed VK All in One Expansion Unit (Unknown): 9.86.0.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | VK All in One Expansion Unit | before 9.86.0.0 | 9.86.0.0 | Patch available | CNA |
- VK All in One Expansion Unit VendorUnknown Affected before 9.86.0.0 Fixed in 9.86.0.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vektor-inc:vk_all_in_one_expansion_unit:*:*:*:*:*:*:*:* | before 9.86.0.0 | Vulnerable | Vektor,Inc. |
- cpe:2.3:a:vektor-inc:vk_all_in_one_expansion_unit:*:*:*:*:*:*:*:* Versions before 9.86.0.0 Vulnerable ·Vektor,Inc.
Remediation
- Fix · CNA VK All in One Expansion Unit (Unknown) Fixed in 9.86.0.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0230
- 2026-10-03 Alias added: GHSA-57cm-qv68-h33c
References
More Vektor,Inc. Vk All In One Expansion Unit vulnerabilities
- TI-2023-00888 VK All in One Expansion Unit < 9.87.1.0 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2024-01949 VK All in One Expansion Unit <= 9.95.0.1 - Information Exposure CVSS 3.1MEDIUM 6.5
- TI-2024-25262 WordPress VK All in One Expansion Unit plugin <= 9.99.1.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-02015 VK All in One Expansion Unit <= 9.96.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via className CVSS 3.1MEDIUM 6.4
- TI-2023-12913 Cross-site scripting in Vektor,Inc. VK All in One Expansion Unit CVSS 3.1MEDIUM 5.4
- TI-2023-12516 Cross-site scripting in Vektor,Inc. VK All in One Expansion Unit CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-0230 · CVE Program
- CVE-2023-0230 · NVD
- FIRST EPSS
- GHSA-57cm-qv68-h33c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences