Priority MEDIUM 60
The VK All in One Expansion Unit WordPress plugin before 9.87.1.0 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00519 · Published 2023-03-20 · Fixed in 9.87.1.0
Priority MEDIUM 58
The VK All in One Expansion Unit WordPress plugin before 9.86.0.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with t…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.0056 · Published 2023-02-27 · Fixed in 9.86.0.0
Priority MEDIUM 40
Deserialization of Untrusted Data vulnerability in Vektor Inc.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00344 · Published 2026-10-05 · No fix listed CWE-502
Priority LOW 36
The VK All in One Expansion Unit plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 9.95.0.1 via social meta tags.
CVSS 3.1MEDIUM 6.5· Network · No auth · No interaction · EPSS 0.00678 · Published 2024-04-09 · No fix listed CWE-200
Priority LOW 29
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Vektor,Inc.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00407 · Published 2025-04-04 · No fix listed CWE-79
Priority LOW 29
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Vektor,Inc.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00313 · Published 2024-07-20 · No fix listed CWE-79
Priority LOW 29
The VK Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'vk-blocks/ancestor-page-list' block in all versions up to, and including, 1.63.0.1 due to insufficient input sanitization…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00635 · Published 2023-11-22 · No fix listed CWE-79
Priority LOW 29
The VK Filter Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'vk_filter_search' shortcode in all versions up to, and including, 2.3.1 due to insufficient input sanitization and…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00508 · Published 2023-10-27 · No fix listed CWE-79
Priority LOW 28
The VK Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Group Block 'linkToPost' Feature in all versions up to, and including, 1.126.1 due to insufficient input sanitization and output escapin…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00184 · Published 2026-10-15 · No fix listed CWE-79
Priority LOW 28
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Vektor,Inc.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00159 · Published 2025-12-16 · No fix listed CWE-79
Priority LOW 28
The VK Google Job Posting Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Job Description field in versions up to, and including, 1.2.23 due to insufficient input sanitization and output…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00276 · Published 2026-01-24 · No fix listed CWE-79
Priority LOW 28
The VK All in One Expansion Unit plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the child page index widget in all versions up to, and including, 9.96.0.1 due to insufficient input sanitization and…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.0034 · Published 2024-03-26 · No fix listed CWE-79
Priority LOW 25
Cross-site scripting vulnerability in CTA post function of VK All in One Expansion Unit 9.88.1.0 and earlier allows a remote authenticated attacker to inject an arbitrary script.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00613 · Published 2023-05-23 · No fix listed CWE-79
Priority LOW 25
Cross-site scripting vulnerability in Profile setting function of VK All in One Expansion Unit 9.88.1.0 and earlier allows a remote authenticated attacker to inject an arbitrary script.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00613 · Published 2023-05-23 · No fix listed CWE-79
Priority LOW 25
Cross-site scripting vulnerability in Post function of VK Blocks 1.53.0.1 and earlier and VK Blocks Pro 1.53.0.1 and earlier allows a remote authenticated attacker to inject an arbitrary script.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00613 · Published 2023-05-23 · No fix listed CWE-79
Priority LOW 25
Cross-site scripting vulnerability in Tag edit function of VK Blocks 1.53.0.1 and earlier and VK Blocks Pro 1.53.0.1 and earlier allows a remote authenticated attacker to inject an arbitrary script.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00613 · Published 2023-05-23 · No fix listed CWE-79
Priority LOW 24
Missing Authorization vulnerability in Vektor,Inc.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00381 · Published 2024-04-26 · No fix listed CWE-862
Priority LOW 22
Cross-site scripting vulnerability exists in VK All in One Expansion Unit versions prior to 9.100.1.0.
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.0031 · Published 2024-11-13 · Fixed in 9.100.1.0 CWE-79
Priority LOW 21
The VK Block Patterns plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.31.1.1.
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00669 · Published 2024-01-20 · No fix listed CWE-352
Priority LOW 21
The VK Blocks plugin for WordPress is vulnerable to improper authorization via the REST 'update_options' function in versions up to, and including, 1.57.0.5.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00503 · Published 2023-06-03 · No fix listed CWE-285
Priority LOW 21
The VK Blocks plugin for WordPress is vulnerable to improper authorization via the REST 'update_vk_blocks_options' function in versions up to, and including, 1.57.0.5.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.0054 · Published 2023-06-03 · No fix listed CWE-285
Priority LOW 20
The VK Blocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.94.2.2 via the page content block.
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00334 · Published 2025-03-07 · No fix listed CWE-284