Read the docs
TI-2023-00888 Aliases CVE-2023-0937GHSA-vv4w-4mwj-jh73

VK All in One Expansion Unit < 9.87.1.0 - Reflected XSS

Priority MEDIUM 60Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The VK All in One Expansion Unit WordPress plugin before 9.87.1.0 does not escape the $_SERVER['REQUEST_URI'] parameter before outputting it back in an attribute, which could lead to Reflected Cross-Site Scripting in old web browsers

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00519 44th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed VK All in One Expansion Unit (Unknown): 9.87.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownVK All in One Expansion Unitbefore 9.87.1.09.87.1.0Patch availableCNA
  • VK All in One Expansion Unit VendorUnknown Affected before 9.87.1.0 Fixed in 9.87.1.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vektor-inc:vk_all_in_one_expansion_unit:*:*:*:*:*:wordpress:*:*before 9.87.1.0VulnerableVektor,Inc.
  • cpe:2.3:a:vektor-inc:vk_all_in_one_expansion_unit:*:*:*:*:*:wordpress:*:* Versions before 9.87.1.0 Vulnerable ·Vektor,Inc.

Remediation

  • Fix · CNA VK All in One Expansion Unit (Unknown) Fixed in 9.87.1.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0937
  2. 2026-10-03 Alias added: GHSA-vv4w-4mwj-jh73

References

  • TI-2023-00220 VK All in One Expansion Unit < 9.86.0.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2024-01949 VK All in One Expansion Unit <= 9.95.0.1 - Information Exposure CVSS 3.1MEDIUM 6.5
  • TI-2024-25262 WordPress VK All in One Expansion Unit plugin <= 9.99.1.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2024-02015 VK All in One Expansion Unit <= 9.96.0.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via className CVSS 3.1MEDIUM 6.4
  • TI-2023-12913 Cross-site scripting in Vektor,Inc. VK All in One Expansion Unit CVSS 3.1MEDIUM 5.4
  • TI-2023-12516 Cross-site scripting in Vektor,Inc. VK All in One Expansion Unit CVSS 3.1MEDIUM 5.4
See all 7 →

Sources