Read the docs
TI-2023-00228 Aliases CVE-2023-0241GHSA-9crj-hpxh-f6qg

Path traversal in pgadmin

Priority MEDIUM 62CWE-22Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

pgAdmin 4 versions prior to v6.19 contains a directory traversal vulnerability. A user of the product may change another user's settings or alter the database.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.08826 95th percentileScored 2026-11-07
Fix Fixed pgadmin4 (PyPI): 6.19

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—pgadminpgadmin 6.19—No fix listedCNA
—pgadmin4 (PyPI)before 6.196.19Patch availableGHSA-9crj-hpxh-f6qg
  • pgadmin Vendor— Affected pgadmin 6.19 Fixed in — No fix listed CNA
  • pgadmin4 (PyPI) Vendor— Affected before 6.19 Fixed in 6.19 Patch available GHSA-9crj-hpxh-f6qg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:*before 6.19Vulnerablepgadmin.org
  • cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:* Versions before 6.19 Vulnerable ·pgadmin.org

Remediation

  • Fix · GHSA-9crj-hpxh-f6qg pgadmin4 (PyPI) Fixed in 6.19 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0241
  2. 2026-10-03 Alias added: GHSA-9crj-hpxh-f6qg

References

  • TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
  • TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
  • TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
  • TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
  • TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
  • TI-2025-11696 Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4) CVSS 3.1CRITICAL 9.8
See all 56 →

Sources