Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
pgAdmin <= 8.4 is affected by a Remote Code Execution (RCE) vulnerability through the validate binary path API. This vulnerability allows attackers to execute arbitrary code on the server hosting PGAdmin, posing a severe risk to the database management system's integrity and the security of the underlying data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | before 8.5 | 8.5 | Patch available | CNA |
| — | pgadmin4 (PyPI) | before 8.5 | 8.5 | Patch available | GHSA-27jx-ffw8-xrqv |
- pgAdmin 4 Vendorpgadmin.org Affected before 8.5 Fixed in 8.5 Patch available CNA
- pgadmin4 (PyPI) Vendor— Affected before 8.5 Fixed in 8.5 Patch available GHSA-27jx-ffw8-xrqv
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* | up to 8.4 | Vulnerable | pgadmin.org |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions up to 8.4 Vulnerable ·pgadmin.org
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA pgAdmin 4 (pgadmin.org) Fixed in 8.5
- Fix · GHSA-27jx-ffw8-xrqv pgadmin4 (PyPI) Fixed in 8.5 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-3116
- 2026-10-03 Alias added: GHSA-27jx-ffw8-xrqv
References
Exploit 3
Other 4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2/
- https://github.com/pgadmin-org/pgadmin4/commit/fbbbfe22dd468bcfef1e1f833ec32289a6e56a8b
- https://github.com/pgadmin-org/pgadmin4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/GIF5T34JTTYRGIN5YPT366BDFG6452A2
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
- TI-2025-11696 Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4) CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-3116 · CVE Program
- CVE-2024-3116 · NVD
- FIRST EPSS
- GHSA-27jx-ffw8-xrqv · GitHub Advisory Database · CC BY 4.0
- CVE-2024-3116 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences