Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
pgAdmin <= 8.3 is affected by a path-traversal vulnerability while deserializing users’ sessions in the session handling code. If the server is running on Windows, an unauthenticated attacker can load and deserialize remote pickle objects and gain code execution. If the server is running on POSIX/Linux, an authenticated attacker can upload pickle objects, deserialize them, and gain code execution.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | before 8.4 | 8.4 | Patch available | CNA |
| — | pgAdmin4 (PyPI) | before 8.4 | 8.4 | Patch available | GHSA-rj98-crf4-g69w |
- pgAdmin 4 Vendorpgadmin.org Affected before 8.4 Fixed in 8.4 Patch available CNA
- pgAdmin4 (PyPI) Vendor— Affected before 8.4 Fixed in 8.4 Patch available GHSA-rj98-crf4-g69w
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* | before 8.4 | Vulnerable | pgadmin.org |
| cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* | 40 | Vulnerable | Fedoraproject |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions before 8.4 Vulnerable ·pgadmin.org
- cpe:2.3:o:fedoraproject:fedora:40:*:*:*:*:*:*:* Versions 40 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA pgAdmin 4 (pgadmin.org) Fixed in 8.4
- Fix · GHSA-rj98-crf4-g69w pgAdmin4 (PyPI) Fixed in 8.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2044
- 2026-10-03 Alias added: GHSA-rj98-crf4-g69w
References
Exploit 1
Advisory 2
Other 5
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LUYN2JXKKHFSVTASH344TBRGWDH64XQV/
- https://github.com/pgadmin-org/pgadmin4/commit/4e49d752fba72953acceeb7f4aa2e6e32d25853d
- https://github.com/pgadmin-org/pgadmin4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LUYN2JXKKHFSVTASH344TBRGWDH64XQV
- https://www.shielder.com/advisories/pgadmin-path-traversal_leads_to_unsafe_deserialization_and_rce
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
- TI-2025-11696 Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4) CVSS 3.1CRITICAL 9.8
Sources
- CVE-2024-2044 · CVE Program
- CVE-2024-2044 · NVD
- FIRST EPSS
- GHSA-rj98-crf4-g69w · GitHub Advisory Database · CC BY 4.0
- CVE-2024-2044 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences