FluentForms < 4.3.25 - Contributor+ Stored XSS via Custom HTML Form Field
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Contact Form Plugin WordPress plugin before 4.3.25 does not properly sanitize and escape the srcdoc attribute in iframes in it's custom HTML field type, allowing a logged in user with roles as low as contributor to inject arbitrary javascript into a form which will trigger for any visitor to the form or admins previewing or editing the form.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Contact Form Plugin | before 4.3.25 | 4.3.25 | Patch available | CNA |
- Contact Form Plugin VendorUnknown Affected before 4.3.25 Fixed in 4.3.25 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:wordpress:*:* | before 4.3.25 | Vulnerable | Fluentforms |
- cpe:2.3:a:fluentforms:contact_form:*:*:*:*:*:wordpress:*:* Versions before 4.3.25 Vulnerable ·Fluentforms
Remediation
- Fix · CNA Contact Form Plugin (Unknown) Fixed in 4.3.25
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0546
- 2026-10-03 Alias added: GHSA-hx6c-3qpr-f44p
References
More Fluentforms Contact Form vulnerabilities
- TI-2022-03198 FluentForm < 4.3.13 - CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2021-13634 CSRF in WP Fluent Forms < 3.6.67 allows stored XSS and Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2024-02582 Missing authorization in techjewel Fluent Forms – Customizable Contact Forms, Survey… CVSS 3.1CRITICAL 9.8
- TI-2023-10032 WordPress FluentForm Plugin <= 4.3.25 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-03867 Deserialization of untrusted data in techjewel Fluent Forms – Customizable Contact Forms… CVSS 3.1HIGH 8.8
- TI-2024-02593 Missing authorization in techjewel Fluent Forms – Customizable Contact Forms, Survey… CVSS 3.1HIGH 7.5
Sources
- CVE-2023-0546 · CVE Program
- CVE-2023-0546 · NVD
- FIRST EPSS
- GHSA-hx6c-3qpr-f44p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences